AC97(4) BSD Programmer's Manual AC97(4)
ac97 - generic AC97 codec driver
AC97 codecs contain the analog-to-digital (A/D), digital-to-analog (D/A), and mixing circuitry of many modern sound cards. AC97 codecs, for the most part, do not talk to host busses like the PCI bus directly. Instead, they communicate through an interface chip, called the host controller. The Ensoniq AudioPCI 97 (see eap(4)) is an example of such a host con- troller. Unlike many drivers, the ac97 driver does not appear in the configuration file. Instead, the driver is automatically attached by the drivers that require it.
auich(4), autri(4), auvia(4), clcs(4), clct(4), eap(4), emu(4), esa(4), fms(4), maestro(4), neo(4), yds(4)
The ac97 driver does not keep track of the current user settings and in- stead relies on the hardware to do this. The ac97 driver could do more to detect mixer channels that don't work and cull them from the list. MirOS BSD #10-current October 7, 1999 1
Generated on 2014-04-02 20:57:59 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.