APM(8) BSD System Manager's Manual APM(8)
apm - Advanced Power Management control program
zzz [-Sz] [-f sockname] apm [-ablmsSvz] [-f sockname]
apm communicates with the Advanced Power Management daemon, apmd(8), mak- ing requests of it for current power status or to place the system into a suspend or stand-by state. With no flags, apm displays the current power management state in verbose form. The options are as follows: -a Display the external charger (A/C status). 0 means disconnected, 1 means connected, 2 means backup power source, and 255 means unknown. -b Display the battery status. 0 means high, 1 means low, 2 means critical, 3 means charging, 4 means absent, and 255 means unk- nown. -f sockname Set the name of the socket via which to contact apmd(8) to sockname. -l Display the estimated battery lifetime (in percent). -m Display the estimated battery lifetime (in minutes). -S Put the system into stand-by (light sleep) mode. -s Display if power management is enabled. -v Request more verbose description of the displayed states. -z Put the system into suspend (deep sleep) mode. The zzz variant on this command is an alternative for suspending the sys- tem. With no arguments, zzz places the system into suspend mode. The com- mand line flags serve the same purpose as for the apm variant of this command. This command does not wait for positive confirmation that the requested mode has been entered; to do so would mean the command does not return until the system resumes from its sleep state.
/var/run/apmdev default Unix domain socket for communicating with apmd(8) The -f flag may be used to specify an alternate socket name. The protec- tion modes on this socket govern which users may access the APM func- tions.
Advanced Power Management (APM) BIOS Interface Specification (revision 1.2), Intel Corporation and Microsoft Corporation
The apm command appeared in NetBSD 1.3, OpenBSD support was added in OpenBSD 1.2. MirOS BSD #10-current March 18, 1996 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.