BOOTPARAMD(8) BSD System Manager's Manual BOOTPARAMD(8)
bootparamd, rpc.bootparamd - boot parameter server
rpc.bootparamd [-d] [-s] [-r router] [-f file]
bootparamd is a server process that provides information to diskless clients necessary for booting. It consults the file /etc/bootparams. It should normally be started from /etc/rc. This version will allow the use of aliases on the hostname in the /etc/bootparams file. The hostname returned in response to the booting client's whoami request will be the name that appears in the config file, not the canonical name. In this way you can keep the answer short enough so that machines that cannot handle long hostnames won't fail during boot. While parsing, if a line containing just "+" is found, and the YP subsys- tem is active, the YP map bootparams will be searched immediately. The options are as follows: -d Display the debugging information. The daemon does not fork in this case. -s Log the debugging information with syslog. -r Set the default router (a hostname or IP address). This defaults to the machine running the server. -f Specify the file to read boot parameters from. Defaults to /etc/bootparams.
/etc/bootparams default configuration file
Originally written by Klas Heggemann <firstname.lastname@example.org>.
You may find the syslog loggings too verbose. It's not clear if the non-canonical hack mentioned above is a good idea.
If rpc.bootparamd is run on a system which is also running YP, your YP domainname will be made public information. MirOS BSD #10-current January 8, 1994 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.