DUMP(8) BSD System Manager's Manual DUMP(8)
dump - filesystem backup
dump [-0123456789acnu] [-B records] [-b blocksize] [-d density] [-f file] [-h level] [-s feet] [-T date] files-to-dump dump [-W | -w] (The 4.3BSD option syntax is implemented for backward compatibility but is not documented here.)
dump examines files on a filesystem and determines which files need to be backed up. These files are copied to the given disk, tape or other storage medium for safe keeping (see the -f option below for doing remote backups). A dump that is larger than the output medium is broken into multiple volumes. On most media the size is determined by writing until an end-of-media indication is returned. This can be enforced by using the -a option. On media that cannot reliably return an end-of-media indication (such as some cartridge tape drives), each volume is of a fixed size; the actual size is determined by the tape size, density and/or block count options below. By default, the same output file name is used for each volume after prompting the operator to change media. files-to-dump is either a mountpoint of a filesystem or a list of files and directories on a single filesystem to be backed up as a subset of the filesystem. In the former case, either the path to a mounted filesystem or the device of an unmounted filesystem can be used. In the latter case, certain restrictions are placed on the backup: -u is ignored, the only dump level that is supported is -0, and all of the files must reside on the same filesystem. Rewinding or ejecting tape features after a close operation on a tape device depend on the name of the tape unit device used. See the -f option and st(4) for more information. The options are as follows: -0-9 Dump levels. A level 0, full backup, guarantees the entire file system is copied (but see also the -h option below). A level number above 0, incremental backup, tells dump to copy all files new or modified since the last dump of a lower level. The default level is 0. -a "auto-size". Bypass all tape length considerations, and enforce writing until an end-of-media indication is returned. This option is recommended for most modern tape drives. Use of this option is particularly recommended when appending to an existing tape, or using a tape drive with hardware compression (where you can never be sure about the compression ratio). -B records The number of kilobytes per volume, rounded down to a multiple of the blocksize. This option overrides the calculation of tape size based on length and density. -b blocksize The number of kilobytes per dump record. Since the IO system slices all requests into chunks of MAXBSIZE (typically 64KB), it is not possible to use a larger blocksize without having problems later with restore(8). Therefore dump will constrain writes to MAXBSIZE. -c Change the defaults for use with a cartridge tape drive, with a density of 8000 bpi, and a length of 1700 feet. -d density Set tape density to density. The default is 1600BPI. -f file Write the backup to file; file may be a special device file like /dev/rst0 (a tape drive), /dev/rsd1c (a disk drive), an ordinary file, or '-' (the standard output). Multiple file names may be given as a single argument separated by commas. Each file will be used for one dump volume in the order listed; if the dump re- quires more volumes than the number of names given, the last file name will be used for all remaining volumes after prompting for media changes. If the name of the file is of the form "host:file" or "user@host:file", dump writes to the named file on the remote host using rmt(8). -h level Honor the user "nodump" flag only for dumps at or above the given level. The default honor level is 1, so that incremental backups omit such files but full backups retain them. -n Whenever dump requires operator attention, notify all operators in the group "operator" by means similar to a wall(1). -s feet Attempt to calculate the amount of tape needed at a particular density. If this amount is exceeded, dump prompts for a new tape. It is recommended to be a bit conservative on this option. The default tape length is 2300 feet. -T date Use the specified date as the starting time for the dump instead of the time determined from looking in /etc/dumpdates. The format of date is the same as that of ctime(3). This option is useful for automated dump scripts that wish to dump over a specific period of time. The -T flag is mutually exclusive from the -u flag. -u Update the file /etc/dumpdates after a successful dump. The for- mat of /etc/dumpdates is human readable, consisting of one free format record per line: filesystem name, increment level and ctime(3) format dump date. There may be only one entry per filesystem at each level. The file /etc/dumpdates may be edited to change any of the fields, if necessary. If a list of files or subdirectories is being dumped (as opposed to an entire filesys- tem), then -u is ignored. -W dump tells the operator what file systems need to be dumped. This information is gleaned from the files /etc/dumpdates and /etc/fstab. The -W flag causes dump to print out, for each file system in /etc/dumpdates, the most recent dump date and level, and highlights those file systems that should be dumped. If the -W flag is set, all other options are ignored, and dump exits im- mediately. -w Same as -W, but prints only those filesystems which need to be dumped. dump requires operator intervention on these conditions: end of tape, end of dump, tape write error, tape open error or disk read error (if there is more than a threshold of 32). In addition to alerting all operators implied by the -n flag, dump interacts with the operator on dump's con- trol terminal at times when dump can no longer proceed, or if something is grossly wrong. All questions dump poses must be answered by typing "yes" or "no", appropriately. Since making a dump involves a lot of time and effort for full dumps, dump checkpoints itself at the start of each tape volume. If writing that volume fails for some reason, dump will, with operator permission, res- tart itself from the checkpoint after the old tape has been rewound and removed, and a new tape has been mounted. dump tells the operator what is going on at periodic intervals, including usually low estimates of the number of blocks to write, the number of tapes it will take, the time to completion, and the time to the tape change. The output is verbose, so that others know that the terminal con- trolling dump is busy, and will be for some time. In the event of a catastrophic disk event, the time required to restore all the necessary backup tapes or files to disk can be kept to a minimum by staggering the incremental dumps. An efficient method of staggering incremental dumps to minimize the number of tapes follows: • Always start with a level 0 backup, for example: # /sbin/dump -0u -f /dev/nrst1 /usr/src This should be done at set intervals, say once a month or once every two months, and on a set of fresh tapes that is saved forever. • After a level 0, dumps of active file systems are taken on a daily basis, using a modified Tower of Hanoi algorithm, with this sequence of dump levels: 3 2 5 4 7 6 9 8 9 9 ... For the daily dumps, it should be possible to use a fixed number of tapes for each day, used on a weekly basis. Each week, a level 1 dump is taken, and the daily Hanoi sequence re- peats beginning with 3. For weekly dumps, another fixed set of tapes per dumped file system is used, also on a cyclical basis. After several months or so, the daily and weekly tapes should get rotated out of the dump cycle and fresh tapes brought in. If dump receives a SIGINFO signal (see the "status" argument of stty(1)) whilst a backup is in progress, statistics on the amount completed, current transfer rate, and estimated finished time, will be written to the standard error output.
TAPE default tape device to use instead of /dev/rst0
/dev/rst0 default tape unit to dump to /dev/rst* raw SCSI tape interface /etc/dumpdates dump date records /etc/fstab dump table: file systems and frequency /etc/group to find group operator
Many, and verbose. dump exits with zero status on success. Startup errors are indicated with an exit code of 1; abnormal termination is indicated with an exit code of 3.
stty(1), fts(3), rcmd(3), st(4), fstab(5), restore(8), rmt(8)
A dump command appeared in Version 5 AT&T UNIX.
Fewer than 32 read errors on the filesystem are ignored. Each reel requires a new process, so parent processes for reels already written just hang around until the entire tape is written. dump with the -W or -w flag does not report filesystems that have never been recorded in /etc/dumpdates, even if listed in /etc/fstab. When dumping a list of files or subdirectories, access privileges are re- quired to scan the directory (as this is done via the fts(3) routines rather than directly accessing the filesystem). It would be nice if dump knew about the dump sequence, kept track of the tapes scribbled on, told the operator which tape to mount when, and pro- vided more assistance for the operator running restore(8). MirOS BSD #10-current June 4, 1997 3
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.