RDATE(8) BSD System Manager's Manual RDATE(8)
rdate - set the system's date from a remote host
rdate [-346adnprsv] [-P ntpport] host
rdate displays and sets the local date and time from the host name or ad- dress given as the argument. The time source may be an RFC 868 TCP proto- col server, which is usually implemented as a built-in service of inetd(8), or an RFC 2030 protocol SNTP/NTP server. By default, rdate uses the RFC 868 TCP protocol. The options are as follows: -3 Sets the NTP protocol version to 3. -4 Forces rdate to use IPv4 addresses only. -6 Forces rdate to use IPv6 addresses only. -a Use the adjtime(2) call to gradually skew the local time to the remote time rather than just hopping. -d Debug the SNTP exchange. If given twice, debug each packet re- ceived. -n Use SNTP (RFC 2030) instead of the RFC 868 time protocol. -P ntpport With -n, use the UDP port ntpport instead of the default 123. -p Do not set, just print the remote time. -r Show the remainder from the last adjtime(2) call. -s Do not print the time. If set, any previous -v options will be ignored. -v Verbose output. Always show the adjustment. Put this on a command line to reset all previous -s options.
/var/log/wtmp record of date resets and time changes
date(1), adjtime(2), crontab(1), gettimeofday(2), symlink(7), inetd(8), ntpd(8), timed(8) MirOS BSD #10-current November 22, 2009 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.