RC.CONF(8) BSD System Manager's Manual RC.CONF(8)
rc.conf - system daemon configuration database
This file contains a series of Bourne-shell syntax assignments that are used to configure the system daemons. It is not read by the kernel, but is sourced by various other files in the /etc/rc.* series in order to set shell variables used therein to control the behaviour of the scripts. It is advisable to leave the /etc/rc.conf file untouched, and instead create and edit a new /etc/rc.conf.local file. Variables set in this file will override variables previously set in /etc/rc.conf. There are three sections in this file. The first is used to turn features on or off. For example, whether the system runs the routed daemon is determined by the line in this section routed=NO # for normal use: "-q" If this line is edited to contain some valid routed daemon command-line flags, such as routed="-q" # for normal use: "-q" then the routed daemon will be started with those options. The second section contains some other programs that can either be run or not, but that don't need options. They can be set to YES or NO. For exam- ple, the line nfs_server=NO prevents the NFS server daemons from starting. To run NFS, just change this line's value from NO to YES, and also make whatever changes are needed for the server to have something to do (set up the exports(5) file etc.). The third section contains values that parameterize servers started by one of the first two sections, and are ignored if the corresponding server is not running. For example, if nfs_server, is enabled, then the line nfsd_flags="-tun 4" provides command-line arguments for the NFS server. This particular line instructs nfsd(8) to start four copies of the server. On a busy file server, 8 (or more) copies are recommended.
init(8), rc(8) and the detailed documentation given for each server that is configurable in this fashion.
The rc.conf file first appeared in OpenBSD 2.2. MirOS BSD #10-current January 5, 1998 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.