NDP(8) BSD System Manager's Manual NDP(8)
ndp - control/diagnose IPv6 Neighbor Discovery Protocol (NDP)
ndp [-nt] hostname ndp [-nt] -a | -c | -p ndp [-nt] -r ndp [-nt] -H | -P | -R ndp [-nt] -A wait ndp [-nt] -d hostname ndp [-nt] -f filename ndp [-nt] -i interface [flags ...] ndp [-nt] -I [interface | delete] ndp [-nt] -s nodename etheraddr [temp] [proxy]
The ndp command manipulates the address mapping table used by the Neigh- bor Discovery Protocol (NDP). -A wait Repeat -a (dump NDP entries) every wait seconds. -a Dump the currently existing NDP entries. The following informa- tion will be printed: Neighbor IPv6 address of the neighbor. Linklayer Address Linklayer address of the neighbor. It could be "(incomplete)" when the address is not available. Netif Network interface associated with the neighbor cache entry. Expire The time until expiry of the entry. The entry could become "permanent", in which case it will never ex- pire. S State of the neighbor cache entry, as a single letter: N Nostate W Waitdelete I Incomplete R Reachable S Stale D Delay P Probe ? Unknown state (should never happen). Flags Flags on the neighbor cache entry, in a single letter. They are: Router, proxy neighbor advertise- ment ("p"). The field could be followed by a decimal number, which means the number of NS probes the node has sent during the current state. -c Erase all the NDP entries. -d Delete specified NDP entry. -f Parse the file specified by filename. -H Harmonize consistency between the routing table and the default router list; install the top entry of the list into the kernel routing table. -I Shows the default interface used as the default route when there is no default router. -I interface Specifies the default interface to be used when there is no in- terface specified even though required. -I delete The current default interface will be deleted from the kernel. -i interface [flags ...] View ND information for the specified interface. If additional arguments flags are given, ndp sets or clears the specified flags for the interface. Each flag should be separated by whitespace or tab characters. Possible flags are as follows. All of the flags can begin with the special character '-', which means the flag should be cleared. Note that you need -- before -foo in this case. nud Turn on or off NUD (Neighbor Unreachability Detection) on the interface. NUD is usually turned on by default. accept_rtadv Specify whether or not to accept Router Advertisement messages received on the interface. Note that the kernel does not accept Router Advertisement messages unless the net.inet6.ip6.accept_rtadv variable is non-0, even if the flag is on. This flag is set to 1 by default. See sysctl(8) and sysctl.conf(5) for further details on how to set the net.inet6.ip6.accept_rtadv variable. -n Do not try to resolve numeric addresses to hostnames. -P Flush all the entries in the prefix list. -p Show prefix list. -R Flush all the entries in the default router list. -r Show default router list. -s Register a NDP entry for a node. The entry will be permanent un- less the word temp is given in the command. If the word proxy is given, this system will act as a proxy NDP server, responding to requests for hostname even though the host address is not its own. -t Print timestamp on each entry, making it possible to merge output with tcpdump(8). Most useful when used with -A.
The ndp command exits with 0 on success, and non-zero on errors.
ip6(4), sysctl.conf(5), arp(8), sysctl(8), tcpdump(8)
The ndp command first appeared in the WIDE Hydrangea IPv6 protocol stack kit. MirOS BSD #10-current May 17, 1998 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.