MirBSD manpage: mount(8)

MOUNT(8)                 BSD System Manager's Manual                  MOUNT(8)

NAME

     mount - mount filesystems

SYNOPSIS

     mount [-Aadfruvw] [-t type]
     mount [-dfruvw] special | node
     mount [-dfruvw] [-o options] [-t type] special node

DESCRIPTION

     The mount command invokes a filesystem specific program to prepare and
     graft the special device or remote node (rhost:path) on to the filesystem
     tree at the point node. If either special or node are not provided, the
     appropriate information is taken from the fstab(5) file.

     For disk partitions, the special device must correspond to a partition
     registered in the disklabel(5).

     The system maintains a list of currently mounted filesystems. If no argu-
     ments are given to mount, this list is printed.

     A mount point node must be an existing directory for a mount to succeed
     (except in the special case of /, of course). Only the superuser may
     mount filesystems unless kern.usermount is nonzero (see sysctl(8)), the
     special device is readable and writeable by the user attempting the
     mount, and the mount point node is owned by the user attempting the
     mount.

     The options are as follows:

     -A      Causes mount to try to mount all of the filesystems listed in the
             fstab(5) table except those for which the "noauto" option is
             specified.

     -a      Similar to the -A flag, except that if a filesystem (other than
             the root filesystem) appears to be already mounted, mount will
             not try to mount it again. mount assumes that a filesystem is al-
             ready mounted if a filesystem with the same type is mounted on
             the given mount point. More stringent checks are not possible be-
             cause some filesystem types report strange values for the
             mounted-from device for mounted file systems.

     -d      Causes everything to be done except for the invocation of the
             filesystem specific program. This option is useful in conjunction
             with the -v flag to determine what the mount command is trying to
             do.

     -f      Either force mounting of dirty filesystems or, in the case of a
             downgrade from read-write to read-only operation, the revocation
             of opened files with write access.

     -o options
             Options can be given with (or without) a 'no' prefix to invert
             their meaning. The options listed below specify non-default
             values. For example, 'noasync' is the default, so 'async' can be
             used to mount a filesystem asynchronously. Multiple options can
             be specified in a comma-separated list. The available options are
             as follows:

             async   All I/O to the filesystem should be done asynchronously.
                     This is a dangerous flag to set since it does not guaran-
                     tee to keep a consistent filesystem structure on the
                     disk. You should not use this flag unless you are
                     prepared to recreate the filesystem should your system
                     crash. The most common use of this flag is to speed up
                     restore(8) where it can give a factor of two speed in-
                     crease.

             softdep
                     (FFS only.) Mount the filesystem using soft dependencies.
                     Instead of metadata being written immediately, it is
                     written in an ordered fashion to keep the on-disk state
                     of the filesystem consistent. This results in significant
                     speedups for file create/delete operations. This option
                     will be ignored when using the -u flag and a filesystem
                     is already mounted read/write. It requires option
                     FFS_SOFTUPDATES to be enabled in the running kernel.

             force   The same as -f; forces the revocation of write access
                     when trying to downgrade a filesystem mount status from
                     read-write to read-only.

             noatime
                     Do not update atime on files in the system unless the
                     mtime or ctime is being changed as well. This option is
                     useful for laptops and news servers where one does not
                     want the extra disk activity associated with updating the
                     atime.

             noaccesstime
                     Synonym for noatime provided for compatibility with other
                     operating systems.

             noauto  Do not mount the filesystem automatically (either at boot
                     or with the -A or -a options).

             nodev   Do not interpret character or block special devices on
                     the filesystem. This option is useful for a server that
                     has filesystems containing special devices for architec-
                     tures other than its own.

             noexec  Do not allow execution of any binaries on the mounted
                     filesystem. This option is useful for a server that has
                     filesystems containing binaries for architectures other
                     than its own.

             nosuid  Do not allow set-user-identifier or set-group-identifier
                     bits to take effect.

             rdonly  The same as -r; mount the filesystem read-only (even the
                     superuser may not write it).

             sync    All I/O to the filesystem should be done synchronously.

             update  The same as -u; indicate that the status of an already
                     mounted filesystem should be changed.

             Any additional options specific to a given filesystem type (see
             the -t option) may be passed as a comma separated list; these op-
             tions are distinguished by a leading "-" (dash). Options that
             take a value are specified using the syntax -option=value. For
             example, the mount command:

                   # mount -t mfs -o nosuid,-s=4000 /dev/sd0b /tmp

             causes mount to execute the equivalent of:

                   # /sbin/mount_mfs -o nosuid -s 4000 /dev/sd0b /tmp

     -r      The filesystem is to be mounted read-only. Mount the filesystem
             read-only (even the superuser may not write it). The same as the
             "rdonly" argument to the -o option.

     -t type
             The argument following the -t is used to indicate the filesystem
             type. The type ffs is the default. The -t option can be used to
             indicate that the actions should only be taken on filesystems of
             the specified type. More than one type may be specified in a com-
             ma separated list. The list of filesystem types can be prefixed
             with "no" to specify the filesystem types for which action should
             not be taken. For example, the mount command:

                   # mount -a -t nonfs,mfs

             mounts all filesystems except those of type NFS and MFS.

             mount will attempt to execute a program in /sbin/mount_XXX where
             XXX is replaced by the type name. For example, NFS filesystems
             are mounted by the program /sbin/mount_nfs.

     -u      The -u flag indicates that the status of an already mounted file
             system should be changed. Any of the options discussed above (the
             -o option) may be changed; also a filesystem can be changed from
             read-only to read-write or vice versa. An attempt to change from
             read-write to read-only will fail if any files on the filesystem
             are currently open for writing unless the -f flag is also speci-
             fied. Only options specified on the command line with -o are
             changed; other filesystem options are unaltered. The options set
             in the fstab(5) table are ignored.

     -v      Verbose mode.

     -w      The filesystem object is to be read and write.

     The options specific to the various filesystem types are described in the
     manual pages for those filesystems' mount_XXX commands. For instance, the
     options specific to Berkeley Fast Filesystems are described in the
     mount_ffs(8) manual page.

FILES

     /etc/fstab  filesystem table

EXAMPLES

     Mount a CD-ROM on node /mnt/cdrom:

           # mount -t cd9660 -r /dev/cd0a /mnt/cdrom

     Mount an MS-DOS floppy on node /mnt/floppy:

           # mount -t msdos /dev/fd0a /mnt/floppy

     Graft a remote NFS filesystem on host host, path /path/name, on node
     /mnt/nfs:

           # mount host:/path/name /mnt/nfs

     Remount /var with option "dev":

           # mount -u -o dev /var

SEE ALSO

     mount(2), fstab(5), disklabel(8), mount_ados(8), mount_cd9660(8),
     mount_ext2fs(8), mount_fdesc(8), mount_ffs(8), mount_kernfs(8),
     mount_mfs(8), mount_msdos(8), mount_nfs(8), mount_ntfs(8),
     mount_portal(8), mount_procfs(8), mount_udf(8), mount_xfs(8), sysctl(8),
     umount(8)

HISTORY

     A mount command appeared in Version 3 AT&T UNIX.

CAVEATS

     After a successful mount, the permissions on the original mount point
     determine if ".." is accessible from the mounted filesystem. The minimum
     permissions for the mount point for traversal across the mount point in
     both directions to be possible for all users is 0111 (execute for all).

MirBSD #10-current              March 27, 1994                               3

Generated on 2022-12-24 01:00:14 by $MirOS: src/scripts/roff2htm,v 1.113 2022/12/21 23:14:31 tg Exp $ — This product includes material provided by mirabilos.

These manual pages and other documentation are copyrighted by their respective writers; their sources are available at the project’s CVSweb, AnonCVS and other mirrors. The rest is Copyright © 2002–2022 MirBSD.

This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report — diffs preferred.

Kontakt / Impressum & Datenschutzerklärung