MAKEWHATIS(8) BSD System Manager's Manual MAKEWHATIS(8)
makewhatis - create a whatis.db database
makewhatis [-p] [manpath ...] makewhatis [-p] -d manpath files ... makewhatis [-p] -u manpath files ... makewhatis [-p] -t files
makewhatis strips the NAME lines from compiled or raw man(1) pages and creates a whatis.db database (that is, a subject index) for use with apropos(1), whatis(1), and man(1)'s -k option. If manpath is unspecified, makewhatis by default creates databases for each directory prefixed by the _whatdb keyword in /etc/man.conf. Man pages compressed with compress(1) and gzip(1) are uncompressed before processing. If the -d option is used, makewhatis merges the description of files with an existing whatis.db database in manpath. If the -u option is used, makewhatis removes the description of files from an existing whatis.db database in manpath. If the -p option is used, makewhatis is less forgiving and warns about incorrect man pages. The -t option can be used to check a set of potential man pages without changing any whatis.db database.
whatis.db index to man pages in directory /etc/man.conf man configuration information
apropos(1), man(1), nroff(1), whatis(1), man.conf(5)
makewhatis should parse /etc/man.conf and deal with extra configuration information. In particular, it does not handle nroff(1) me format. Like- wise, its use of heuristics to retrieve subjects from most man pages is not 100% accurate. MirOS BSD #10-current October 17, 1997 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.