LOCATE.UPDATEDB(8) BSD System Manager's Manual LOCATE.UPDATEDB(8)
locate.updatedb - update locate database
locate.updatedb [--tmpdir=dir] [--fcodes=dbfile] [-- searchpaths='dir1 -dir2...'] [-- prunepaths='dir1 -dir2...'] [-- filesystems='type1 -type2...']
locate.updatedb updates the database used by locate(1). It is typically run once a week by the /etc/weekly script. The contents of the newly built database can be controlled by the /etc/locate.rc file as well as the command line arguments. The options are as follows: --tmpdir Sets the directory temporary files are stored in. --fcodes Use the named file as the find codes database. If the file name '-' is given, the database will be sent to standard output. --searchpaths Sets the list of directories to be put in the database. --prunepaths Sets the list of parent directories that should not go in the da- tabase. --filesystems A list of filesystem types to be traversed by find(1).
/etc/locate.rc configuration file /var/db/locate.database default database
find(1), locate(1), weekly(8) Woods, James A., "Finding Files Fast", ;login, 8:1, pp. 8-10, 1983. MirOS BSD #10-current February 11, 1996 1
Generated on 2015-04-13 10:26:13 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.