ISDNTRACE(8) BSD System Manager's Manual ISDNTRACE(8)
isdntrace - isdn4bsd ISDN protocol trace utility
isdntrace [-a] [-b] [-d] [-f filename] [-h] [-i] [-l] [-n number] [-o] [-p filename] [-r] [-u number] [-x] [-B] [-F] [-P] [-R unit] [-T unit]
isdntrace is part of the isdn4bsd package and is used to provide the user with a mnemonic display of the layers 1, 2 and 3 protocol activities on the D channel and hex dump of the B channel(s) activities. Together with two passive supported cards and an easy to build cable it can also be used to monitor the complete traffic on a S0 bus providing S0 bus analyzer features. The isdntrace utility is only available for passive supported cards. Note All filenames, user specified or default, get a date and time stamp string added in the form -yymmdd-hhmmss: a hyphen, two digits year, month, day, a hyphen and two digits hour, minutes and seconds. Trace files no longer get overwritten. In case a new filename is needed within a second, the filename-generating mechanism sleeps one second. In case the program is sent a USR1 signal, a new user specified or de- fault filename with a new date and time stamp is generated and opened. The following options can be used: -a Run isdntrace in analyzer mode by using two passive cards and a custom cable which can be build as described in the file cable.txt in the isdn4bsd source distribution. One card acts as a receiver for the transmitting direction on the S0 bus while the other card acts as a receiver for the receiving direction on the S0 bus. Complete traffic monitoring is possible using this setup. -b switch B channel tracing on (default off). -d switch D channel tracing off (default on). -f Use filename as the name of a file into which to write tracing output (default filename is isdntrace<n> where n is the number of the unit to trace). -h switch display of header off (default on). -i print layer 1 (I.430) INFO signals to monitor layer 1 activity (default off). -l switch displaying of Layer 2 (Q.921) frames off (default on). -n This option takes a numeric argument specifying the minimum frame size in octets a frame must have to be displayed. (default 0) -o switch off writing trace output to a file (default on). -p Use filename as the name of a file used for the -B and -P options (default filename is isdntracebin<n> where n is the number of the unit to trace). -r Switch off printing a raw hexadecimal dump of the packets preced- ing the decoded protocol information (default on). -u Use number as the unit number of the controller card to trace (default 0). -x Switch on printing of packets with a non-Q.931 protocol discrimi- nator. (default off). -B Write undecoded binary trace data to a file for later or remote analyzing (default off). -F This option can only be used when option -P (playback from binary data file) is used. The -F option causes playback not to stop at end of file but rather to wait for additional data to be avail- able from the input file. This option is useful when trace data is accumulated in binary format (to save disk space) but a monitoring functionality is desired. (default off). -P Read undecoded binary trace data from file instead from device (default off). -R Use unit as the receiving interface unit number in analyze mode. -T Use unit as the transmitting interface unit number in analyze mode. When the USR1 signal is sent to a isdntrace process, the currently used logfiles are reopened, so that logfile rotation becomes possible. The trace output should be obvious. It is very handy to have the follow- ing standard texts available when tracing ISDN protocols: I.430 ISDN BRI layer 1 protocol description. Q.921 ISDN D-channel layer 2 protocol description. Q.931 ISDN D-channel layer 3 protocol description. 1TR6 German-specific ISDN layer 3 protocol description. (NOTICE: decoding of the 1TR6 protocol is included but not supported since i dont have any longer access to a 1TR6 based ISDN installation.) isdntrace automatically detects the layer 3 protocol being used by look- ing at the Protocol Discriminator (see: Q.931/1993 pp. 53).
/dev/isdntrc<n> The device file(s) used to get the trace messages for ISDN card unit <n> out of the kernel.
The command: isdntrace -f /var/tmp/isdn.trace will start D channel tracing on passive controller 0 with all except B channel tracing enabled and logs everything into the output file /var/tmp/isdn.trace-yymmdd-hhmmss (where yymmdd and hhmmss are replaced by the current date and time values).
ITU Recommendations I.430, Q.920, Q.921, Q.930, Q.931 FTZ Richtlinie 1TR3, Band III ITU Recommendation Q.932 (03/93), Q.950 (03/93) ETSI Recommendation ETS 300 179 (10/92), ETS 300 180 (10/92) ETSI Recommendation ETS 300 181 (04/93), ETS 300 182 (04/93) ITU Recommendation X.208, X.209
The isdntrace utility was written by Gary Jennejohn and Hellmuth Michaelis. This manual page was written by Hellmuth Michaelis <firstname.lastname@example.org>. MirOS BSD #10-current February 13, 2000 2
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.