ISDNTELCTL(8) BSD System Manager's Manual ISDNTELCTL(8)
isdntelctl - control isdn4bsd telephone sound format conversion
isdntelctl [-c] [-g] [-u unit] [-A] [-U] [-N]
isdntelctl is part of the isdn4bsd package and is used to configure the sound format conversion facilities of the /dev/isdntel interfaces. The following options are available: -c Clear the telephone input queue. -g Get the sound format currently in use. -u Set the /dev/isdntel unit number. The default value is zero to access device /dev/isdntel0. -A Do A-law (ISDN line) -> mu-law (userland) conversion. -U Do mu-law (ISDN line) -> A-law (userland) conversion. -N Set sound conversion to do no format conversion. The telephony data stream comes out of the line in a bit-reversed format, so the isdntel(4) driver does the bit-reversion process in any case. Additionally, the user can specify to do A-law to mu-law, mu-law to A-law or no conversion at all in the isdntel driver by using the isdntelctl utility.
The command isdntelctl -g displays the currently used sound format for device /dev/isdntel0.
isdntel(4), isdnd.rc(5), isdnd(8)
A-law and mu-law are specified in ITU Recommendation G.711.
The isdntelctl utility and this man page were written by Hellmuth Michaelis <firstname.lastname@example.org>. MirOS BSD #10-current April 21, 1999 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.