REBOOT(8) BSD System Manager's Manual REBOOT(8)
reboot, halt - stopping and restarting the system
halt [-dnpq] reboot [-dnq]
The halt and reboot utilities flush the file system cache to disk, run the system shutdown script, send all running processes a SIGHUP, SIGTERM and one or more SIGKILL, and, respectively, halt or restart the system. The action is logged, including entering a shutdown record into the login accounting file. The options are as follows: -d Causes system to create a dump before rebooting. This option is useful for debugging system dump procedures or capturing the state of a corrupted or misbehaving system. See savecore(8) for information on how to recover this dump. -n Prevent file system cache from being flushed. This option should probably not be used. -p Causes the system to power down, if it is being halted, and the hardware supports automatic power down. -q Quick. The system is halted or restarted quickly and ungraceful- ly, and only the flushing of the file system cache is performed. This option should probably not be used. Normally, the shutdown(8) utility is used when the system needs to be halted or restarted, giving users advance warning of their impending doom.
/etc/rc.shutdown script which is run at shutdown time by /etc/rc /var/db/host.random where 2 KiB entropy are stored before reboot(2)
reboot(2), utmp(5), boot_i386(8), boot_sparc(8), rc.shutdown(8), savecore(8), shutdown(8), sync(8)
A reboot command appeared in Version 6 AT&T UNIX. MirOS BSD #10-current February 19, 2011 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.