GETTY(8) BSD System Manager's Manual GETTY(8)
getty - set terminal mode
getty [type [tty]]
The getty program is called by init(8) to open and initialize the tty line, read a login name, and invoke login(1). The argument tty is the special device file in /dev to open for the ter- minal (for example, ``ttyh0''). If there is no argument or the argument is '-', the tty line is assumed to be open as file descriptor 0. The type argument can be used to make getty treat the terminal line spe- cially. This argument is used as an index into the gettytab(5) database, to determine the characteristics of the line. If there is no argument, or there is no such table, the default table is used. If there is no /etc/gettytab a set of system defaults is used. If indicated by the table located, getty will clear the terminal screen, print a banner heading, and prompt for a login name. Usually either the banner or the login prompt will include the system hostname. Most of the default actions of getty can be circumvented, or modified, by a suitable gettytab(5) table. The getty program can be set to timeout after some interval, which will cause dial up lines to hang up if the login name is not entered reason- ably quickly.
getty is started by init(8), with a process priority, umask, and resource limits based on the "default" entry in /etc/login.conf.
ttyxx: No such device or address. ttyxx: No such file or address. A terminal which is turned on in the ttys(5) file cannot be opened, likely because the requisite lines are ei- ther not configured into the system, the associated device was not at- tached during boot-time system configuration, or the special file in /dev does not exist.
login(1), ioctl(2), tty(4), gettytab(5), login.conf(5), ttys(5), init(8)
A getty program appeared in Version 6 AT&T UNIX. MirOS BSD #10-current June 4, 1993 1
Generated on 2014-04-02 20:57:59 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.