FSCK_MSDOS(8) BSD System Manager's Manual FSCK_MSDOS(8)
fsck_msdos - DOS/Windows (FAT) file system consistency checker
fsck_msdos [-fpny] filesystem ...
The fsck_msdos utility verifies and repairs FAT file systems (more com- monly known as DOS file systems). It checks the specified file systems and tries to repair all detected inconsistencies, requesting confirmation before making any changes. If the -p flag is given, fsck_msdos preens the specified file systems. It is normally started this way by fsck(8) run from rc(8) during automatic reboot, when a FAT file system is detected. When preening file systems, fsck_msdos will fix common inconsistencies non-interactively. If more serious problems are found, fsck_msdos does not try to fix them, indi- cates that it was not successful, and exits. The options are as follows: -f This option is ignored by fsck_msdos, and is present only for compatibility with programs that check other file system types for consistency, such as fsck_ffs(8). -n Assume a "no" response to all questions asked by fsck_msdos ex- cept for "CONTINUE?", which is assumed to be affirmative. File systems will not be opened for writing. This is the default for file systems to be checked that are concurrently mounted writ- able. -p Preen the specified file systems. -y Causes fsck_msdos to assume "yes" as the answer to all operator questions.
fs(5), fstab(5), fsck(8), fsck_ffs(8), mount_msdos(8), newfs_msdos(8), rc(8)
fsck_msdos is still under construction. MirOS BSD #10-current August 13, 1995 1
Generated on 2014-04-02 20:57:59 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.