FSCK_EXT2FS(8) BSD System Manager's Manual FSCK_EXT2FS(8)
fsck_ext2fs - Second Extended File System consistency check and interac- tive repair
fsck_ext2fs [-dfnpy] [-b block#] [-m mode] filesystem ...
fsck_ext2fs performs interactive file system consistency checks and repairs for each of the file systems specified. It is normally invoked from fsck(8). The kernel takes care that only a restricted class of innocuous file sys- tem inconsistencies can happen unless hardware or software failures in- tervene. These are limited to the following: Unreferenced inodes Link counts in inodes too large Missing blocks in the free map Blocks in the free map also in files Counts in the super-block wrong These are the only inconsistencies that fsck_ext2fs in "preen" mode (with the -p option) will correct; if it encounters other inconsistencies, it exits with an abnormal return status. For each corrected inconsistency one or more lines will be printed identifying the file system on which the correction will take place, and the nature of the correction. After successfully correcting a file system, fsck_ext2fs will print the number of files on that file system and the number of used and free blocks. If sent a QUIT signal, fsck_ext2fs will finish the file system checks, then exit with an abnormal return status. Without the -p option, fsck_ext2fs audits and interactively repairs in- consistent conditions for file systems. If the file system is incon- sistent, the operator is prompted for concurrence before each correction is attempted. It should be noted that some of the corrective actions which are not correctable under the -p option will result in some loss of data. The amount and severity of data lost may be determined from the di- agnostic output. The default action for each consistency correction is to wait for the operator to respond "yes" or "no". If the operator does not have write permission on the file system, fsck_ext2fs will default to a -n action. The following flags are interpreted by fsck_ext2fs: -b block# Use the block specified immediately after the flag as the super block for the file system. Block 8193 is usually an alternate super block. -d Print debugging output. -f Force checking of file systems. Normally, if a file system is cleanly unmounted, the kernel will set a "clean flag" in the file system superblock and fsck_ext2fs will not check the file system. This option forces fsck_ext2fs to check the file system, regard- less of the state of the clean flag. -m mode Use the mode specified in octal as the permission bits to use when creating the lost+found directory rather than the default 1777. In particular, systems that do not wish to have lost files accessible by all users on the system should use a more restric- tive set of permissions such as 700. -n Assume a "no" response to all questions asked by fsck_ext2fs ex- cept for "CONTINUE?", which is assumed to be affirmative. File systems will not be opened for writing. This is the default for file systems to be checked that are concurrently mounted writ- able. -p Specify "preen" mode, described above. -y Assume a "yes" response to all questions asked by fsck_ext2fs; this should be used with great caution as this is a free license to continue after essentially unlimited trouble has been encoun- tered. Inconsistencies checked are as follows: 1. Blocks claimed more than once by inodes or the free map. 2. Blocks claimed by an inode outside the range of the file system. 3. Incorrect link counts. 4. Size checks: Directory size not a multiple of file system block size. Partially truncated file. 5. Bad inode format. 6. Blocks not accounted for anywhere. 7. Directory checks: File pointing to unallocated inode. Inode number out of range. Dot or dot-dot not the first two entries of a directory or having the wrong inode number. 8. Super Block checks: More blocks for inodes than there are in the file system. Bad free block map format. Total free block and/or free inode count incorrect. Orphaned files and directories (allocated but unreferenced) are, with the operator's concurrence, reconnected by placing them in the lost+found directory. The name assigned is the inode number. If the lost+found directory does not exist, it is created. If there is insufficient space its size is increased. Because of inconsistencies between the block device and the buffer cache, the raw device should always be used.
The diagnostics produced by fsck_ext2fs are fully enumerated and ex- plained in Appendix A of Fsck_ffs - The UNIX File System Check Program.
fs(5), fstab(5), fsck(8), mount_ext2fs(8), rc(8) Fsck_ffs - The UNIX File System Check Program, /usr/share/doc/smm/03.fsck_ffs. MirOS BSD #10-current June 13, 1997 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.