FSINFO(8) BSD System Manager's Manual FSINFO(8)
ffsinfo - dump all meta information of an existing ufs file system
ffsinfo [-L] [-g cylinder_group] [-i inode] [-l level] [-o outfile] special | file
The ffsinfo utility extends the dumpfs(8) utility. The output is generated into the file outfile. Also expect the output file to be rather large. Up to 2 percent of the size of the specified file system is not uncommon. The following options are available: -L Specifying this option skips the tests of the disklabel. This is done automatically, if the specified filename to dump is a plain file. -g cylinder_group This restricts the dump to information about this cylinder group only. Here 0 means the first cylinder group and -1 the last one. -i inode This restricts the dump to information about this particular inode only. Here the minimum acceptable inode is 2. If this op- tion is omitted but a cylinder group is defined then only inodes within that cylinder group are dumped. -l level The level of detail which will be dumped. This value defaults to 255 and is the "bitwise or" of the following table: 0x001 initial superblock 0x002 superblock copies in each cylinder group 0x004 cylinder group summary in initial cylinder group 0x008 cylinder group information 0x010 inode allocation bitmap 0x020 fragment allocation bitmap 0x040 cluster maps and summary 0x080 rotational layout tables 0x100 inode information 0x200 indirect block dump -o outfile This allows to change the output filename where the dump is writ- ten to. The current default is /var/tmp/ffsinfo. If - is provid- ed, output will be sent to stdout.
ffsinfo -l 1023 /dev/rwd0f will dump /dev/rwd0f with all available information.
Currently ffsinfo can only dump unmounted file systems. Do not try dump- ing a mounted file system, your system may panic and you will not be able to use the file system any longer. Also snapshots are handled like plain files. They should get their own level to provide for independent control of the amount of what gets dumped. It probably also makes sense to some extend to dump the snapshot as a file system.
disklabel(8), dumpfs(8), fsck(8), growfs(8), newfs(8), tunefs(8)
Christoph Herrmann <chm@FreeBSD.org> Thomas-Henning von Kamptz <tomsoft@FreeBSD.org> The GROWFS team <growfs@Tomsoft.COM>
The ffsinfo utility first appeared in FreeBSD 4.4. MirOS BSD #10-current September 8, 2000 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.