EDITMAP(8) BSD System Manager's Manual EDITMAP(8)
editmap - query and edit records in database maps for sendmail
editmap [-C file] [-N] [-f] [-q | -u | -x] maptype mapname key ["value ..."]
editmap queries or edits one record in database maps used by the keyed map lookups in sendmail(8). Arguments are passed on the command line and output (for queries) is directed to standard output. Depending on how it is compiled, editmap handles up to three different database formats, selected using the maptype parameter. They may be dbm DBM format maps. This requires the ndbm(3) library. btree B-Tree format maps. This requires the new Berkeley DB li- brary. hash Hash format maps. This also requires the Berkeley DB library. If the TrustedUser option is set in the sendmail configuration file and editmap is invoked as root, the generated files will be owned by the specified TrustedUser.
-C file Use the specified sendmail(8) configuration file for looking up the TrustedUser option. -N Include the null byte that terminates strings in the map (for alias maps). -f Normally all upper case letters in the key are folded to lower case. This flag disables that behaviour. This is in- tended to mesh with the -f flag in the "K" line in sendmail.cf. The value is never case folded. -q Query the map for the specified key. If found, print value to standard output and exit with 0. If not found then print an error message to stdout and exit with EX_UNAVAILABLE. -u Updates the record for key with value or inserts a new record if one doesn't exist. Exits with 0 on success or EX_IOERR on failure. -x Deletes the specific key from the map. Exits with 0 on suc- cess or EX_IOERR on failure.
The editmap command appeared in OpenBSD 3.0. MirOS BSD #10-current December 19, 2010 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.