DHCP(8) BSD System Manager's Manual DHCP(8)
dhcp - configuring OpenBSD for DHCP
The Dynamic Host Configuration Protocol (DHCP) allows hosts on a TCP/IP network to configure one or more network interfaces based on information collected from a DHCP server in response to a DHCP request. This mechan- ism is often used, for example, by cable modem and DSL network providers to simplify network configurations for their clients/customers. Information typically contained within a DHCP response includes an IP ad- dress for the interface, subnet mask, broadcast address, router (gateway) listing, domain name server listing, and the interface's MTU. To set up OpenBSD as a DHCP client: 1. For each interface that is to be configured via DHCP, create a /etc/hostname.XXX file (where XXX is the interface's identif- ier, e.g., ep1) that starts with the word "dhcp", optionally followed by additional interface options. See hostname.if(5) for more information on the format of these files. The /etc/netstart script reads each of these hostname files at boot-time and runs the dhclient(8) program for each interface that is to be configured via DHCP. 2. [Optional] To tweak settings, edit /etc/dhclient.conf. This file is shipped with the system. See dhclient.conf(5) and dhclient(8) for details. To set up OpenBSD as a DHCP server: 1. Edit /etc/dhcpd.conf. This file is shipped with the system. See dhcpd.conf(5) and dhcpd(8) for details. 2. Edit /etc/dhcpd.interfaces. This file should contain a list of interfaces you wish to serve by dhcpd(8). If you have only one broadcast network interface or you wish to serve all inter- faces, this step is not required. Be sure to leave this file empty (or even delete it) if this is the case. 3. Edit /etc/rc.conf.local and set dhcpd_flags="". This will cause OpenBSD to start the dhcpd(8) daemon at boot-time and listen for DHCP requests on the local network. To start it manually, execute the following commands: # touch /var/db/dhcpd.leases # /usr/sbin/dhcpd -q [netif1 netif2 ...] 4. Ensure the kernel has been compiled with BPF (Berkeley Packet Filter) support and at least one /dev/bpf* file exists per broadcast network interface that is attached to the system. This is almost always the case and should only be considered if all other troubleshooting options have failed. See dhcpd(8) for information on other available options. Note, however, that most of the flags are useful only for debugging purposes.
/etc/dhcpd.conf DHCP server configuration file /etc/dhcpd.interfaces list of network interfaces served by dhcpd(8) /etc/rc.conf.local configuration file where dhcpd_flags must be set /etc/dhclient.conf DHCP client configuration file /etc/hostname.XXX interface-specific configuration files
dhclient.conf(5), dhcpd.conf(5), hostname.if(5), dhclient(8), dhcpd(8), dhcrelay(8) MirOS BSD #10-current July 8, 1999 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.