CHROOT(8) BSD System Manager's Manual CHROOT(8)
chroot - change root directory
chroot [-g group,group,...] [-u user] newroot [command]
The chroot command changes its root directory to the supplied directory newroot and executes command, if supplied, or an interactive copy of the user's shell. The chroot command is restricted to the superuser. The options are as follows: -g group,group,... Override the primary and supplemental group IDs. The primary group ID is set to the first group in the list. Any remaining groups are placed in the supplemental group ID vector. Each group listed must exist in the group(5) databases. -u user Set user ID to user (which must exist in the passwd(5) database). The primary and supplemental group IDs will be set based on the user's entries in the passwd(5) and group(5) databases unless overridden by the -g option.
SHELL If set, the string specified by SHELL is interpreted as the name of the shell to execute. If the variable SHELL is not set, /bin/sh is used.
chdir(2), chroot(2), setgid(2), setgroups(2), setuid(2), group(5), passwd(5), environ(7)
The chroot utility first appeared in 4.4BSD.
chroot should never be installed setuid root, as it would then be possi- ble to exploit the program to gain root privileges. MirOS BSD #10-current February 7, 2003 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.