APMD(8) BSD System Manager's Manual APMD(8)
apmd - Advanced Power Management monitor daemon
apmd [-ademps] [-f devname] [-S sockname] [-t seconds]
apmd monitors the advanced power management (APM) pseudo-device, acting on signaled events and upon user requests as sent by the apm(8) program. For suspend and standby request events delivered by the BIOS, or via apm(8), apmd runs the appropriate configuration program (if one exists), syncs the buffer cache to disk and initiates the requested mode. When resuming after suspend or standby, apmd runs the appropriate configura- tion program (if one exists). For power status change events, apmd fetches the current status and reports it via syslog(3) with logging fa- cility LOG_DAEMON. apmd periodically polls the APM driver for the current power state. If the battery charge level changes substantially or the external power status changes, the new status is logged. The polling rate defaults to once per 10 minutes, but may be specified using the -t command-line flag. If the -s flag is specified, the current battery statistics are reported via syslog(3) and apmd exits without monitoring the APM status. If the -a flag is specified, any BIOS-initiated suspend or standby re- quests are ignored if the system is connected to line current and not running from batteries (user requests are still honored). If the -d flag is specified, apmd enters debug mode, logging to facility LOG_LOCAL1 and staying in the foreground on the controlling terminal. If the -m flag is specified, apmd does not disable power status messages issued by the APM driver. In normal operation these status messages are disabled as they are the same as the information collected by this daemon and reported via syslog. The -e and -p flags are used to re-enable APM driver power status mes- sages. In both cases apmd exits immediately after setting the desired op- tion. The -e flag unconditionally enables power status messages. The -p flag causes power status messages to be displayed only when the battery life expectancy changes. This minimizes message output for those devices that are constantly updating the estimated time remaining based upon current processor load. However, in no case will power status messages be displayed until the battery life goes below the percentage in the sysctl(8) state variable machdep.apmwarn. Setting machdep.apmwarn to zero disables all warnings. When a client requests a suspend or stand-by mode, apmd does not wait for positive confirmation that the requested mode has been entered before re- plying to the client; to do so would mean the client does not get a reply until the system resumes from its sleep state. Rather, apmd replies with the intended state to the client and then places the system in the re- quested mode after running the configuration script and flushing the buffer cache. Actions can be configured for the following five transitions: suspend, standby, resume, powerup and powerdown. The suspend and standby actions are run prior to apmd performing any other actions (such as disk syncs) and entering the new mode. The resume program is run after resuming from a stand-by or suspended state. The powerup and powerdown programs are run after the power status (AC connected or not) changes, as well as after a resume (if the power status changed in the mean time).
/etc/apm/suspend, /etc/apm/standby, /etc/apm/resume, /etc/apm/powerup and /etc/apm/powerdown are the files that contain the host's customized ac- tions. Each file must be an executable binary or shell script suitable for execution by the execve(2) function. If you wish to have the same program or script control all transitions, it may determine which transi- tion is in progress by examining its argv which is set to one of suspend, standby, resume, powerup and powerdown. /var/run/apmdev is the default UNIX-domain socket used for communication with apm(8). The -S flag may be used to specify an alternate socket name. The socket is protected to mode 0660, UID 0, GID 0; this protects access to suspend requests to authorized users only. /dev/apmctl is the default device used to control the APM kernel driver. The -f flag may be used to specify an alternate device file name.
execve(2), syslog(3), apm(4), apm(8), sysctl(8), syslogd(8)
Advanced Power Management (APM) BIOS Interface Specification (revision 1.2), Intel Corporation and Microsoft Corporation.
The apmd command appeared in NetBSD 1.3. OpenBSD support was added in OpenBSD 1.2. MirOS BSD #10-current March 24, 1996 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.