RTADVD.CONF(5) BSD Reference Manual RTADVD.CONF(5)
rtadvd.conf - config file for router advertisement daemon
This file describes how the router advertisement packets must be con- structed for each of the interfaces. As described in rtadvd(8), you do not have to set this configuration file up at all, unless you need some special configurations. You may even omit the file as a whole. In such cases, the rtadvd daemon will automatically configure itself using default values specified in the specification. It obeys the famous termcap(5) file format. Each line in the file describes a network interface. Fields are separated by a colon (':'), and each field contains one capability description. Lines may be concatenated by the '\' character. The comment marker is the '#' character.
Capabilities describe the value to be filled into ICMPv6 router adver- tisement messages and to control rtadvd(8) behavior. Therefore, you are encouraged to read IETF neighbor discovery documents if you would like to modify the sample configuration file. Note that almost all items have default values. If you omit an item, the default value of the item will be used. There are two items which control the interval of sending router adver- tisements. These items can be omitted, then rtadvd will use the default values. maxinterval (num) The maximum time allowed between sending unsolicited multi- cast router advertisements (unit: seconds). The default value is 600. Its value must be no less than 4 seconds and no greater than 1800 seconds. mininterval (num) The minimum time allowed between sending unsolicited multi- cast router advertisements (unit: seconds). The default value is the one third of value of maxinterval. Its value must be no less than 3 seconds and no greater than .75 * the value of maxinterval. The following items are for ICMPv6 router advertisement message header. These items can be omitted, then rtadvd will use the default values. chlim (num) The value for Cur Hop Limit field. The default value is 64. raflags (num) Flags field in router advertisement message header. Bit 7 (0x80) means Managed address configuration flag bit, and Bit 6 (0x40) means Other stateful configuration flag bit. The default value is 0. rltime (num) Router lifetime field (unit: seconds). Its value must be no greater than 3600000. When rtadvd runs on a host, this value must explicitly set 0 on all the advertising interfaces as described in rtadvd(8). The default value is 1800. rtime (num) Reachable time field (unit: milliseconds). The default value is 0, which means unspecified by this router. retrans (num) Retrans Timer field (unit: milliseconds). The default value is 0, which means unspecified by this router. The following items are for ICMPv6 prefix information option, which will be attached to router advertisement header. These items can be omitted, then rtadvd will automatically get appropriate prefixes from the kernel's routing table, and advertise the prefixes with the default parameters. Keywords other than clockskew can be augmented with a number, like "prefix2", to specify multiple prefixes. clockskew (num) Time skew to adjust link propagation delays and clock skews between routers on the link (unit: seconds). This value is used in consistency check for locally-configured and advertised prefix lifetimes, and has its meaning when the local router configures a prefix on the link with a lifetime that decrements in real time. If the value is 0, it means the consistency check will be skipped for such prefixes. The default value is 0. prefixlen (num) Prefix length field. The default value is 64. pinfoflags (num) Flags field in prefix information option. Bit 7 (0x80) means On-link flag bit, and Bit 6 (0x40) means Autonomous address-configuration flag bit. The default value is 0xc0, i.e., both bits are set. addr (str) The address filled into Prefix field. Since ":" is used for the termcap(5) file format as well as IPv6 numeric addresses, the field MUST be quoted using double quotes. vltime (num) Valid lifetime field (unit: seconds). The default value is 2592000 (30 days). vltimedecr (bool) This item means the advertised valid lifetime will decre- ments in real time, which is disabled by default. pltime (num) Preferred lifetime field (unit: seconds). The default value is 604800 (7 days). pltimedecr (bool) This item means the advertised preferred lifetime will de- crements in real time, which is disabled by default. The following item is for ICMPv6 MTU option, which will be attached to router advertisement header. This item can be omitted, then rtadvd will use the default value. mtu (num or str) MTU (maximum transmission unit) field. If 0 is specified, it means that the option will not be included. The de- fault value is 0. If the special string "auto" is specified for this item, MTU option will be included and its value will be set to the interface MTU automatically. The following item controls ICMPv6 source link-layer address option, which will be attached to router advertisement header. As noted above, you can just omit the item, then rtadvd will use the default value. nolladdr (bool) By default (if nolladdr is not specified), rtadvd(8) will try to get link-layer address for the interface from the kernel, and attach that in source link-layer address option. If this ca- pability exists, rtadvd(8) will not attach source link-layer ad- dress option to router advertisement packets. You can also refer one line from another by using tc capability. See termcap(5) for details on the capability.
As presented above, all of the advertised parameters have default values defined in specifications, and hence you usually do not have to set them by hand, unless you need special non-default values. It can cause intero- perability problem if you use an ill-configured parameter. To override a configuration parameter, you can specify the parameter alone. With the following configuration, rtadvd(8) overrides the router lifetime parameter for the ne0 interface. ne0:\ :rltime#0: The following example manually configures prefixes advertised from the ef0 interface. The configuration must be used with the -s option to rtadvd(8). ef0:\ :addr="3ffe:501:ffff:1000::":prefixlen#64: The following example presents the default values in an explicit manner. The configuration is provided just for reference purposes; YOU DO NOT NEED TO HAVE IT AT ALL. default:\ :chlim#64:raflags#0:rltime#1800:rtime#0:retrans#0:\ :pinfoflags="la":vltime#2592000:pltime#604800:mtu#0: ef0:\ :addr="3ffe:501:ffff:1000::":prefixlen#64:tc=default:
termcap(5), rtadvd(8), rtsol(8) Thomas Narten, Erik Nordmark and W. A. Simpson, "Neighbor Discovery for IP version 6 (IPv6)", RFC 2461
The rtadvd(8) and the configuration file rtadvd.conf first appeared in WIDE Hydrangea IPv6 protocol stack kit. MirOS BSD #10-current May 17, 1998 2
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.