NETGROUP(5) BSD Reference Manual NETGROUP(5)
netgroup - defines network groups
The netgroup file specifies "netgroups", which are sets of (host, user, domain) tuples that are to be given similar network access. Each line in the file consists of a netgroup name followed by a list of the members of the netgroup. Each member can be either the name of anoth- er netgroup or a specification of a tuple as follows: (host, user, domain) where the host, user, and domain are character string names for the corresponding component. Any of the comma separated fields may be empty to specify a "wildcard" value or may consist of the single character "-" to specify "no valid value". The members of the list may be separated by whitespace; the "\" character may be used at the end of a line to specify line continuation. The functions specified in getnetgrent(3) should nor- mally be used to access the netgroup database. These functions operate on the db(3) version of the netgroup (netgroup.db) file which can be generated using netgroup_mkdb(8). If that file is not present, and the system supports NIS, then the netgroup NIS maps are used. The NIS maps are also used if the netgroup file contains a "+" entry. Lines that begin with a '#' are treated as comments.
/etc/netgroup default netgroup list /etc/netgroup.db netgroup database
getnetgrent(3), exports(5), netgroup_mkdb(8)
The file format is compatible with that of various vendors, although it appears that not all vendors use an identical format.
The interpretation of access restrictions based on the member tuples of a netgroup is left up to the various network applications. MirOS BSD #10-current December 11, 1993 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.