MAILER.CONF(5) BSD Reference Manual MAILER.CONF(5)
mailer.conf - configuration file for mailwrapper(8)
The file /etc/mailer.conf contains a series of pairs. The first member of each pair is the name of a program invoking mailwrapper(8) which is typi- cally a symbolic link to /usr/sbin/sendmail. (On a typical system, newaliases(8) and mailq(8) would be set up this way.) The second member of each pair is the name of the program to actually execute when the first name is invoked. The file may also contain comments, denoted by a '#' character in the first column of any line.
The following is an example of how to set up mailer.conf for traditional sendmail(8) invocation behavior. # Execute the "real" sendmail program, named /usr/libexec/sendmail/sendmail sendmail /usr/libexec/sendmail/sendmail send-mail /usr/libexec/sendmail/sendmail mailq /usr/libexec/sendmail/sendmail makemap /usr/libexec/sendmail/makemap newaliases /usr/libexec/sendmail/sendmail hoststat /usr/libexec/sendmail/sendmail purgestat /usr/libexec/sendmail/sendmail This example shows how to invoke the postfix MTA suite in place of sendmail(8). # Emulate sendmail using postfix sendmail /usr/local/sbin/sendmail send-mail /usr/local/sbin/sendmail mailq /usr/local/sbin/sendmail makemap /usr/local/sbin/makemap #XXX ? newaliases /usr/local/sbin/sendmail
mail(1), mailq(8), mailwrapper(8), newaliases(8), sendmail(8)
Perry E. Metzger <firstname.lastname@example.org>
The entire reason this program exists is a crock. Instead, a command for how to submit mail should be standardized, and all the "behave different- ly if invoked with a different name" behavior of things like mailq(8) should go away. MirOS BSD #10-current December 19, 2010 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.