MirBSD manpage: genassym.cf(5)

GENASSYM.CF(5)               BSD Reference Manual               GENASSYM.CF(5)

NAME

     genassym.cf - assym.h definition file

DESCRIPTION

     The genassym.cf file is used by genassym.sh(8) to make constant C expres-
     sions known to assembler source files.

     Lines starting with '#' are discarded by genassym.sh(8). Lines starting
     with include, ifdef, if, else or endif are preceded with '#' and passed
     otherwise unmodified to the C compiler.

     Lines starting with quote get passed on with the quote command removed.

     The first word after a define command is taken as a CPP identifier and
     the rest of the line has to be a constant C expression. The output of
     genassym.sh(8) will assign the numerical value of this expression to the
     CPP identifier.

     export foo
     is a shorthand for
     define foo foo.

     struct foo
     remembers foo for the member command and does a
     define FOO_SIZEOF sizeof(foo),
     with the structure name converted to upper case.

     member foo
     does a
     define FOO offsetof(<last struct>, foo).
     The two argument form of member, as
     member foo bar
     does a
     define FOO offsetof(<last struct>, bar),
     with its first argument converted to upper case. In the case where struct
     was invoked with an extra argument, as in
     struct foo PREFIX_,
     the first argument of member will be prefixed by the remembered prefix,
     before being converted to upper case.

     union foo
     is similar to the struct command, but applies to a union instead of a
     struct.

     config <ctype> <gcc constraint> <asm print modifier>
     can be used to customize the output of genassym.sh(8).
     When producing C output, values are cast to <ctype> (default: long) be-
     fore they get handed to printf. <gcc constraint> (default: n) is the con-
     straint used in the __asm__ statements. <asm print modifier> (default:
     empty) can be used to force gcc to output operands in different ways than
     normal. The "a" modifier e.g. stops gcc from emitting immediate prefixes
     in front of constants for the i386 and m68k port.

FILES

     /sys/arch/${MACHINE}/${MACHINE}/genassym.cf

SEE ALSO

     genassym.sh(8)

HISTORY

     The first use of genassym.cf files occurred in OpenBSD 2.2. Its use was
     generalized to all ports for OpenBSD 3.0. The union command appeared in
     OpenBSD 3.5.

MirBSD #10-current              April 25, 1998                               1

Generated on 2022-12-24 01:00:14 by $MirOS: src/scripts/roff2htm,v 1.113 2022/12/21 23:14:31 tg Exp $ — This product includes material provided by mirabilos.

These manual pages and other documentation are copyrighted by their respective writers; their sources are available at the project’s CVSweb, AnonCVS and other mirrors. The rest is Copyright © 2002–2022 MirBSD.

This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report — diffs preferred.

Kontakt / Impressum & Datenschutzerklärung