MirBSD manpage: dir(5), dirent(5)

DIR(5)                       BSD Reference Manual                       DIR(5)

NAME

     dir, dirent - directory file format

SYNOPSIS

     #include <sys/types.h>
     #include <dirent.h>

DESCRIPTION

     Directories provide a convenient hierarchical method of grouping files
     while obscuring the underlying details of the storage medium. A directory
     file is differentiated from a plain file by a flag in its inode(5) entry.
     It consists of records (directory entries) each of which contains infor-
     mation about a file and a pointer to the file itself. Directory entries
     may contain other directories as well as plain files; such nested direc-
     tories are referred to as subdirectories. A hierarchy of directories and
     files is formed in this manner and is called a filesystem (or referred to
     as a filesystem tree).

     Each directory file contains two special directory entries; one is a
     pointer to the directory itself called dot (".") and the other a pointer
     to its parent directory called dot-dot (".."). Dot and dot-dot are valid
     pathnames, however, the system root directory ("/"), has no parent and
     dot-dot points to itself like dot.

     Filesystem nodes are ordinary directory files on which has been grafted a
     filesystem object, such as a physical disk or a partitioned area of such
     a disk (see mount(8)).

     The directory entry format is defined in the file <dirent.h>:

     /*
      * A directory entry has a struct dirent at the front of it, containing
      * its inode number, the length of the entry, and the length of the name
      * contained in the entry.  These are followed by the name padded to a 4
      * byte boundary with null bytes.  All names are guaranteed NUL terminated.
      * The maximum length of a name in a directory is MAXNAMLEN.
      */

     struct dirent {
             u_int32_t       d_fileno;       /* file number of entry */
             u_int16_t       d_reclen;       /* length of this record */
             u_int8_t        d_type;         /* file type, see below */
             u_int8_t        d_namlen;       /* length of string in d_name */
     #define MAXNAMLEN       255
             char    d_name[MAXNAMLEN + 1];  /* maximum name length */
     };

     /*
      * File types
      */
     #define DT_UNKNOWN      0
     #define DT_FIFO         1
     #define DT_CHR          2
     #define DT_DIR          4
     #define DT_BLK          6
     #define DT_REG          8
     #define DT_LNK          10
     #define DT_SOCK         12

     /*
      * Convert between stat structure types and directory types.
      */
     #define IFTODT(mode)    (((mode) & 0170000) >> 12)
     #define DTTOIF(dirtype) ((dirtype) << 12)
     #ifdef _POSIX_SOURCE
     typedef void *  DIR;
     #else

     #define d_ino           d_fileno        /* backward compatibility */

     /* definitions for library routines operating on directories. */
     #define DIRBLKSIZ       1024

     /* structure describing an open directory. */
     typedef struct _dirdesc {
             int     dd_fd;     /* file descriptor associated with directory */
             long    dd_loc;    /* offset in current buffer */
             long    dd_size;   /* amount of data returned by getdirentries */
             char    *dd_buf;   /* data buffer */
             int     dd_len;    /* size of data buffer */
             long    dd_seek;   /* magic cookie returned by getdirentries */
             long    dd_rewind; /* magic cookie for rewinding */
             int     dd_flags;  /* flags for readdir */
     } DIR;

     #define dirfd(dirp)     ((dirp)->dd_fd)

     /* flags for opendir2 */
     #define DTF_NODUP       0x0002  /* don't return duplicate names */
     #define __DTF_READALL   0x0008  /* everything has been read */

     #endif /* _POSIX_SOURCE */

SEE ALSO

     getdirentries(2), fs(5), inode(5)

HISTORY

     A dir file format appeared in Version 7 AT&T UNIX.

MirBSD #10-current               May 3, 1995                                 1

Generated on 2022-12-24 01:00:14 by $MirOS: src/scripts/roff2htm,v 1.113 2022/12/21 23:14:31 tg Exp $ — This product includes material provided by mirabilos.

These manual pages and other documentation are copyrighted by their respective writers; their sources are available at the project’s CVSweb, AnonCVS and other mirrors. The rest is Copyright © 2002–2022 MirBSD.

This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report — diffs preferred.

Kontakt / Impressum & Datenschutzerklärung