HOSTS.EQUIV(5) BSD Reference Manual HOSTS.EQUIV(5)
hosts.equiv, .rhosts - trusted remote hosts and host-user pairs
The hosts.equiv and .rhosts files list hosts and users which are "trusted" by the local host when a connection is made via rshd(8), or any other server that uses ruserok(3). This mechanism bypasses password checks, and is required for access via rsh(1). Each line of these files has the format: hostname [username] The hostname may be specified as a host name (typically a fully qualified host name in a DNS environment) or address, +@netgroup (from which only the host names are checked), or a '+' wildcard (allow all hosts). The username, if specified, may be given as a user name on the remote host, +@netgroup (from which only the user names are checked), or a '+' wildcard (allow all remote users). If a username is specified, only that user from the specified host may login to the local machine. If a username is not specified, any user may login with the same user name.
somehost A common usage; users on somehost may login to the local host as the same user name. somehost username The user username on somehost may login to the local host. If specified in /etc/hosts.equiv, the user may login with only the same user name. +@anetgroup username The user username may login to the local host from any machine listed in the netgroup anetgroup. + + + Two severe security hazards. In the first case, allows a user on any machine to login to the local host as the same user name. In the second case, allows any user on any machine to login to the lo- cal host (as any user, if in /etc/hosts.equiv).
The user name checks provided by this mechanism are not secure, as the remote user name is received by the server unchecked for validity. There- fore this mechanism should only be used in an environment where all hosts are completely trusted. A numeric host address instead of a host name can help security con- siderations somewhat; the address is then used directly by iruserok(3). When a user name (or netgroup, or '+') is specified in /etc/hosts.equiv, that user (or group of users, or all users, respectively) may login to the local host as any local user. Usernames in /etc/hosts.equiv should therefore be used with extreme caution, or not at all. A .rhosts file must be owned by the user whose home directory it resides in, and must be writable only by that user. Logins as root only check root's .rhosts file; the /etc/hosts.equiv file is not checked for security. Access permitted through root's .rhosts file is typically only for rsh(1).
/etc/hosts.equiv global trusted host-user pairs list ~/.rhosts per-user trusted host-user pairs list
rcp(1), rsh(1), rcmd(3), ruserok(3), netgroup(5)
The .rhosts file format appeared in 4.2BSD.
The ruserok(3) implementation currently skips negative entries (preceded with a '-' sign) and does not treat them as "short-circuit" negative en- tries. MirOS BSD #10-current November 26, 1997 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.