WSMOUSE(4) BSD Programmer's Manual WSMOUSE(4)
wsmouse - generic mouse support in wscons
wsmouse* at pms? mux 0 (PS/2 mouse) wsmouse* at pmsi? mux 0 ( "IntelliMouse" -compatible wheel mouse with PS/2 interface) wsmouse* at ums? mux 0 (USB mouse) wsmouse* at lms? mux 0 (Logitech bus mouse, i386 only) wsmouse* at mms? mux 0 (Microsoft InPort mouse, i386 only) wsmouse* at ams? mux 0 (Apple ADB mouse) wsmouse* at hilms? mux 0 (HIL mouse)
The wsmouse driver is an abstraction layer for mice within the wscons(4) framework. It is attached to the hardware specific keyboard drivers and provides a character device interface. For use with X servers, "mouse events" can be generated. The wsmouse driver provides a number of ioctl functions to control vari- ous parameters (see /usr/include/dev/wscons/wsconsio.h). The wsconsctl(8) utility gives access to these variables.
ams(4), hilms(4), intro(4), lms(4), mms(4), pms(4), ums(4), wscons(4), wsmux(4), wsconsctl(8), wsmoused(8) MirOS BSD #10-current March 20, 1999 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.