WDC(4) BSD Programmer's Manual WDC(4)
wdc - WD100x compatible hard disk controller driver
# alpha/i386 wdc0 at isa? port 0x1f0 irq 14 flags 0x00 wdc1 at isa? port 0x170 irq 15 flags 0x00 wdc* at isapnp? # macppc wdc* at macobio? wdc* at kauaiata? # all architectures wdc* at pcmcia? function ? atapiscsi* at wdc?* channel ? flags 0x0000 wd* at wdc? drive ? flags 0x0000
The wdc driver provides the basic functions for the wd(4) and atapiscsi(4) drivers. It supports IDE and EIDE controllers, as well as MFM, RLL, and ESDI on the ISA bus. PCI IDE controllers in legacy mode are also supported, but the pciide(4) driver may provide more functionality. For the isa(4) front-end, setting flags to 0x01 enables 32-bit I/O nego- tiation. This is known to cause problems with some motherboards.
atapiscsi(4), intro(4), isa(4), isapnp(4), macobio(4), pciide(4), pcmcia(4), scsi(4), wd(4) MirOS BSD #10-current October 15, 1998 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.