VIAENV(4) BSD Programmer's Manual VIAENV(4)
viaenv - VIA VT82C686A hardware monitor
viaenv* at pci? dev ? function ?
The viaenv driver provides support for the hardware monitor in the VIA VT82C686A and VT8231 South Bridge to be used with the sysctl(8) inter- face. The device has 10 sensors: Sensor Units Typical Use TSENS1 uK CPU temperature TSENS2 uK System temperature TSENS3 uK Unknown FAN1 RPM CPU fan FAN2 RPM System fan VSENS1 uV DC CPU core voltage (2.0V) VSENS2 uV DC North Bridge core voltage (2.5V) Vcore uV DC Internal core voltage (3.3V) VSENS3 uV DC +5V VSENS4 uV DC +12V Sensor data is updated every 1.5 seconds.
The viaenv driver first appeared in NetBSD 1.5, OpenBSD support was added in OpenBSD 3.4.
The viaenv driver was written by Johan Danielsson and ported to OpenBSD 3.4 by Alexander Yurchenko <firstname.lastname@example.org>.
Interrupt support is unimplemented, as is support for setting values. MirOS BSD #10-current May 8, 2000 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.