UHIDEV(4) BSD Programmer's Manual UHIDEV(4)
uhidev - USB Human Interface Device support
uhidev* at uhub? port ? configuration ? uhid* at uhidev? reportid ? ukbd* at uhidev? reportid ? ums* at uhidev? reportid ?
The uhidev driver handles all Human Interface Devices. Each HID device can have several components, e.g., a keyboard and a mouse. These com- ponents use different report identifiers (a byte) to distinguish which one data is coming from. The uhidev driver has other drivers attached that handle particular kinds of devices and uhidev only dispatches data to them based on the report id.
intro(4), uhid(4), ukbd(4), ums(4), usb(4)
The uhidev driver appeared in OpenBSD 3.2. MirOS BSD #10-current December 27, 2001 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.