TB(4) BSD Programmer's Manual TB(4)
tb - line discipline for digitizing devices
pseudo-device tb [count]
This line discipline provides a polled interface to many common digitiz- ing devices which are connected to a host through a serial line. When these devices stream data at high speed, the use of the line discipline is critical in minimizing the number of samples that would otherwise be lost due to buffer exhaustion in the tty(4) handler. The line discipline is enabled by a sequence: #include <sys/tablet.h> int ldisc = TABLDISC, fildes; ... ioctl(fildes, TIOCSETD, &ldisc); A typical application program then polls the digitizing device by reading a binary data structure which contains: the current X and Y positions (in the device coordinate space), up-down status of the buttons or pen stylus, proximity information (when available), and a count of the number of samples received from the input device since it was opened. In addi- tion, devices such as the GTCO append tilt and pressure information to the end of the aforementioned structure. For the Polhemus 3-D digitizer the structure read is completely different. Refer to the include file for a complete description. While in tablet mode, normal teletype input and output functions take place. Thus, if an 8 bit output data path is desired, it is necessary to prepare the output line by putting it into RAW mode using ioctl(2). This must be done before changing the discipline with TIOCSETD, as most ioctl(2) calls are disabled while in tablet line-discipline mode. The line discipline supports ioctl(2) requests to get/set the operating mode, and to get/set the tablet type and operating mode by or-ing the two values together. Calling read(2) on the device always succeeds, returning the last sample, although the select(2) and poll(2) system calls will correctly report the read state for new samples. The line discipline supports digitizing devices which are compatible with Hitachi, GTCO, or Polhemus protocol formats. For Hitachi there are several formats with that used in the newer model HDG-1111B the most com- mon.
The tb interface appeared in 4.3BSD. MirOS BSD #10-current March 27, 1991 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.