STI(4) BSD Programmer's Manual STI(4)
sti - HP Standard Text Interface
sti* at mainbus0 irq ? sti* at phantomas0 irq ? wsdisplay* at sti? console ?
The sti was created by HP to provide uniform frame-buffer access opera- tions for their 9000/300 and 9000/700 series of workstations. Implementa- tion consists of a set of functions burnt in to the PROM on the card and providing the following set of functions (see below for PROM revision history on functions supported by particular PROM revision): • Initialize graphics. • State management. • Print a character onto the screen using currently selected font. • Copy a region of the frame-buffer to another location. • Self testing. • Exception handling. • Frame-buffer configuration enquiry. • Setting colour-map entry. • DMA parameters. • Flow control. • User timing. • Processing management. • Miscellaneous utility functions. There are two modes for accessing the PROM: "byte" and "word" mode. In "byte" mode each 4-byte word contains only the low-ordered big-endian byte of data; i.e., to compose one word of data 4 words should be read and low-ordered bytes of those should be shifted correspondingly. In "word" mode each word contains all 4 bytes of valid data. PROM revision history: 8.02 Original release. 8.03 • OSF-extended self test (a.k.a fast). • Restore display. 8.04 • Implement curr_mon function. • Implement "block move". • Implement "set colour-map entry". sti Implement word mode. • Support for multiple monitors. • Support user_data sti space usage. • Support for extra memory. • Support for Windows NT (tm). • Monitor frequency reference. • Early console. • Support added for: PCXL, GSC bus, ROM-less operation. 8.05 • Interrupt support. • Report card's power usage. • Birds of Prey. • User interrupts. 8.06 • Multiple fonts. • Monitor table descriptor strings. • PCXL2 and PCXU monitor descriptors. 8.08 • HP-UX 10 support for Visualize FX • dma_ctrl function added. • flow_ctrl function added. • user_timing function added. 8.09 • Addition changes for Visualize FX due to rearchitecture for performance. • process_mgr function added. 8.0a PCXL2 and PCXU dual PCI EPROM map mode, implemented on Visualize EG. 8.0b Support for HP-UX non-implicit locking DMA, implemented on Visualize FXE. 8.0c sti_util function added (flashing under HP-UX and other sideband traffic). 8.0d Colour frame buffer support.
intro(4), phantomas(4), wsdisplay(4) Standard Text Interface For Graphics Devices, Hewlett-Packard, Revision 8.13, March 1, 2000.
The sti driver was written by Michael Shalayeff <firstname.lastname@example.org> for HPPA port for OpenBSD 2.7.
Currently, neither scroll back nor screen blanking functions are imple- mented. MirOS BSD #10-current May 11, 2001 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.