STE(4) BSD Programmer's Manual STE(4)
ste - Sundance Technologies ST201 Fast Ethernet driver
ste* at pci? dev ? function ?
The ste driver provides support for PCI Ethernet adapters and embedded controllers based on the Sundance Technologies ST201 PCI fast Ethernet controller chip. This includes the D-Link DFE-550TX. The Sundance ST201 uses bus master DMA and is designed to be a 3Com Eth- erLink XL work-alike. It uses the same DMA descriptor structure and is very similar in operation, however its register layout is different. The ST201 has a 64-bit multicast hash filter and a single perfect filter en- try for the station address. It supports both 10 and 100Mbps speeds in either full or half duplex using an MII transceiver. The ste driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the hostname.if(5) file. 10baseT Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. The ste driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. For more information on configuring this device, see ifconfig(8).
ste%d: couldn't map ports/memory A fatal initialization error has oc- curred. ste%d: couldn't map interrupt A fatal initialization error has occurred. ste%d: watchdog timeout The device has stopped responding to the net- work, or there is a problem with the network connection (cable). ste%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring. ste%d: no memory for tx list The driver failed to allocate an mbuf for the transmitter ring when allocating a pad buffer or collapsing an mbuf chain into a cluster. ste%d: chip is in D3 power state -- setting to D0 This message applies only to adapters which support power management. Some operating systems place the controller in low power mode when shutting down, and some PCI BIOSes fail to bring the chip out of this state before configuring it. The controller loses all of its PCI configuration in the D3 state, so if the BIOS does not set it back to full power mode in time, it won't be able to configure it correctly. The driver tries to detect this condition and bring the adapter back to the D0 (full power) state, but this may not be enough to return the driver to a fully operational condition. If this message appears at boot time and the driver fails to attach the device as a network interface, a second warm boot will have to be performed to have the device properly configured. Note that this condition only occurs when warm booting from another operating system. If the system is powered down prior to booting OpenBSD, the card should be configured correctly.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8) Sundance ST201 data sheet, http://www.sundanceti.com.
The ste device driver first appeared in FreeBSD 3.0. OpenBSD support was added in OpenBSD 2.7.
The ste driver was written by Bill Paul <firstname.lastname@example.org> and port- ed to OpenBSD by Aaron Campbell <email@example.com>. MirOS BSD #10-current August 21, 1999 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.