SF(4) BSD Programmer's Manual SF(4)
sf - Adaptec AIC-6915 Starfire PCI Fast Ethernet driver
sf* at pci? dev ? function ?
The sf driver provides support for Adaptec Duralink Fast Ethernet adapters based on the Adaptec AIC-6915 "Starfire" chipset. This includes the following: • ANA-62011 64-bit single port 10/100baseTX • ANA-62022 64-bit dual port 10/100baseTX • ANA-62044 64-bit quad port 10/100baseTX • ANA-69011 32-bit single port 10/100baseTX • ANA-62020 64-bit single port 100baseFX The AIC-6915 is a bus master controller with an MII interface. It sup- ports high and low priority transmit and receive queues, TCP/IP checksum offload, multiple DMA descriptor formats and both polling and producer/consumer DMA models. The AIC-6915 receive filtering options in- clude a 16 entry perfect filter, a 512-bit hash table for multicast ad- dresses, a 512-bit hash table for priority address matching and VLAN filtering. An external MII-compliant transceiver is required for media interfacing. Multiport adapters consist of several AIC-6915 controllers connected via a PCI to PCI bridge. Each controller is treated as a separate interface by the sf driver. The sf driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the hostname.if(5) file. 10baseT Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. The sf driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. For more information on configuring this device, see ifconfig(8).
sf%d: couldn't map memory A fatal initialization error has occurred. This may happen if the PCI BIOS did not configure the device, which can occur when the BIOS has been configured for a "Plug and Play" operating system. The "Plug and Play OS" setting in the BIOS should be set to "no" or "off" in order for PCI devices to work properly with OpenBSD. sf%d: couldn't map ports A fatal initialization error has occurred. This may happen if the PCI BIOS did not configure the device, which can occur when the BIOS has been configured for a "Plug and Play" operating system. The "Plug and Play OS" setting in the BIOS should be set to "no" or "off" in order for PCI devices to work properly with OpenBSD. sf%d: couldn't map interrupt A fatal initialization error has occurred. sf%d: no memory for softc struct! The driver failed to allocate memory for per-device instance information during initialization. sf%d: failed to enable I/O ports/memory mapping! The driver failed to initialize PCI I/O port or shared memory access. This might happen if the card is not in a bus-master slot. sf%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8) The Adaptec AIC-6915 Programmer's Manual, ftp://ftp.adaptec.com/pub/BBS/userguides/aic6915_pg.pdf.
The sf device driver first appeared in OpenBSD 2.7.
The sf driver was written by Bill Paul <firstname.lastname@example.org>. MirOS BSD #10-current July 22, 1999 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.