MirBSD manpage: rl(4)
RL(4) BSD Programmer's Manual RL(4)
rl - Realtek 8129/8139 Fast Ethernet driver
rl* at pci? dev ? function ?
rl* at cardbus? dev ? function ?
The rl driver provides support for PCI Ethernet adapters and embedded
controllers based on the Realtek 8129 and 8139 Fast Ethernet controller
chips. This includes, among others, the following cards:
Accton MPX5030 CardBus
Allied Telesyn AT2550
Corega FEther CB-TXD 10/100 Ethernet
D-Link DFE530TX+, DFE538TX, DFE-690TXD
Encore ENL832-TX 10/100 M PCI
Genius GF100TXR
KTX-9130TX 10/100 Fast Ethernet
Longshine LCS-8038TX-R
NDC Communications NE100TX-E
Netronix Inc. EA-1210 NetEther 10/100
Nortel BayStack 21
OvisLink LEF-8129TX, LEF-8139TX
SMC EZ Card 10/100 PCI 1211-TX
TrendNet TE100-PCBUSR CardBus
The Realtek controllers use bus master DMA but do not use a descriptor-
based data transfer mechanism. The receiver uses a single fixed size ring
buffer from which packets must be copied into mbufs. For transmission,
there are only four outbound packet address registers which require all
outgoing packets to be stored as contiguous buffers. Furthermore, out-
bound packet buffers must be longword aligned or else transmission will
fail.
The 8129 differs from the 8139 in that the 8139 has an internal PHY which
is controlled through special direct access registers whereas the 8129
uses an external PHY via an MII bus. The 8139 supports both 10 and
100Mbps speeds in either full or half duplex. The 8129 can support the
same speeds and modes given an appropriate PHY chip.
The rl driver supports the following media types:
autoselect Enable autoselection of the media type and options. This is
only supported if the PHY chip attached to the Realtek con-
troller supports NWAY autonegotiation. The user can manually
override the autoselected mode by adding media options to
the appropriate hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
modes.
The rl driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
Note that the 100baseTX media type is only available if supported by the
adapter. For more information on configuring this device, see
ifconfig(8).
rl%d: couldn't map memory A fatal initialization error has occurred.
rl%d: couldn't map interrupt A fatal initialization error has occurred.
rl%d: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
rl%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
rl%d: no memory for tx list The driver failed to allocate an mbuf for
the transmitter ring when allocating a pad buffer or collapsing an mbuf
chain into a cluster.
rl%d: chip is in D3 power state -- setting to D0 This message applies
only to adapters which support power management. Some operating systems
place the controller in low power mode when shutting down, and some PCI
BIOSes fail to bring the chip out of this state before configuring it.
The controller loses all of its PCI configuration in the D3 state, so if
the BIOS does not set it back to full power mode in time, it won't be
able to configure it correctly. The driver tries to detect this condition
and bring the adapter back to the D0 (full power) state, but this may not
be enough to return the driver to a fully operational condition. If this
message appears at boot time and the driver fails to attach the device as
a network interface, a second warm boot will have to be performed to have
the device properly configured.
Note that this condition only occurs when warm booting from another
operating system. If the system is powered down prior to booting OpenBSD,
the card should be configured correctly.
arp(4), ifmedia(4), intro(4), netintro(4), hostname.if(5), ifconfig(8)
The Realtek 8129 and 8139 datasheets, ftp.realtek.com.tw:/lancard/data
sheet.
The rl device driver first appeared in FreeBSD 3.0. OpenBSD support first
appeared in OpenBSD 2.5.
The rl driver was written by Bill Paul <wpaul@ctr.columbia.edu>.
Since outbound packets must be longword aligned, the transmit routine has
to copy an unaligned packet into an mbuf cluster buffer before transmis-
sion. The driver abuses the fact that the cluster buffer pool is allocat-
ed at system startup time in a contiguous region starting at a page boun-
dary. Since cluster buffers are 2048 bytes, they are longword aligned by
definition. The driver probably should not be depending on this charac-
teristic.
The Realtek data sheets are of especially poor quality: the grammar and
spelling are awful and there is a lot of information missing, particular-
ly concerning the receiver operation. One particularly important fact
that the data sheets fail to mention relates to the way in which the chip
fills in the receive buffer. When an interrupt is posted to signal that a
frame has been received, it is possible that another frame might be in
the process of being copied into the receive buffer while the driver is
busy handling the first one. If the driver manages to finish processing
the first frame before the chip is done DMAing the rest of the next
frame, the driver may attempt to process the next frame in the buffer be-
fore the chip has had a chance to finish DMAing all of it.
The driver can check for an incomplete frame by inspecting the frame
length in the header preceding the actual packet data: an incomplete
frame will have the magic length of 0xFFF0. When the driver encounters
this value, it knows that it has finished processing all currently avail-
able packets. Neither this magic value nor its significance are document-
ed anywhere in the Realtek data sheets.
MirBSD #10-current November 4, 1998 2