POWERNOWHACK(4) BSD Programmer's Manual (i386) POWERNOWHACK(4)
powernowhack - a pseudo-device for the AMD K7 PowerNow extension
powernowhack0 at mainbus0 flags 0x0000
MirOS provides support for the PowerNow function of recent AMD K7 proces- sors in order to save power or reduce heat. This is the kernel driver for setting the CPU speed via sysctl(8) using the hw.setperf knob and report- ing the result using the hw.cpuspeed control. Flags is a bit mask which specifies how the driver operates. 0x8000 Override BIOS function. Do not look for a PST whose signature matches the CPUID. Instead, only use the specified PST. 0x4000 Verbose operation. Print a list of all PSTs shown even if we find a PST matching the CPUID or the user has disabled the functionality by selecting PST 0xFFF. 0x0nnn Select PST nnn. nnn is a hexadecimal value (three nibbles) specifying the number of the PST to use. PSTs are numbered linearily, starting from 001. If nnn is 000 (default), additional output (the CPUID on which no signature matches) is shown and PST #001 is used. If nnn is FFF, the PowerNow function is disabled if no PST match- ing the CPUID is found or flag 0x8000 is also specified.
0x0000 Default. Look for a matching PST, use first and list PSTs if none found. 0x0FFF Look for a matching PST, disable K7PN if none found. 0x4FFF List PSTs, then look for a matching PST and disable K7PN is none found. 0x8002 Do not bother looking for a matching PST. Use the second PST. 0xC002 Like 0x8002, but list all PSTs first.
apm(4), intro(4), sysctl(3), sysctl(8)
The powernowhack driver appeared in MirOS #8 and is based upon a third- party patch for NetBSD which has not yet made it into an official tree.
powernowhack originated as a patch by Martin Vegiard <firstname.lastname@example.org>, was integrated into OpenBSD by Ted Unangst <email@example.com> and turned into a driver for MirOS by Thorsten Glaser <firstname.lastname@example.org>.
Using a mismatching PST may damage your CPU or induce fire in your com- puter. MirOS BSD #10-current May 4, 2005 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.