LM(4) BSD Programmer's Manual LM(4)
lm - National Semiconductor LM78, LM79 and compatible hardware monitors
lm0 at isa? port 0x290 lm1 at isa? port 0x280 lm2 at isa? port 0x310
The lm driver provides support for the National Semiconductor LM series hardware monitors and register compatible chips to be used with the sysctl(8) interface. Most supported devices possess 11 sensors: Sensor Units Typical Use IN0 uV DC Core voltage IN1 uV DC Unknown IN2 uV DC +3.3V IN3 uV DC +5V IN4 uV DC +12V IN5 uV DC -12V IN6 uV DC -5V Temp uK Motherboard Temperature Fan0 RPM Fan Fan1 RPM Chassis Fan Fan2 RPM Fan For some devices (most Winbond devices), sensors' names and numbers will be different. Due to hardware limitations, fresh sensor data is only available every 1.5 seconds.
Chips supported by the lm driver include: National Semiconductor LM78 and LM78-J National Semiconductor LM79 Winbond W83697HF Winbond W83627HF, W83627THF, W83781D and W83782D
The lm driver first appeared in NetBSD 1.5, OpenBSD support was added in OpenBSD 3.4.
The lm driver was written by Bill Squier and ported to OpenBSD 3.4 by Alexander Yurchenko <firstname.lastname@example.org>.
Interrupt support is unimplemented. There are currently no known pnpbios IDs assigned to LM chips. MirOS BSD #10-current February 26, 2000 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.