MirBSD manpage: lkm(4)

LKM(4)                     BSD Programmer's Manual                      LKM(4)

NAME

     LKM - Loadable Kernel Modules interface

SYNOPSIS

     option LKM

DESCRIPTION

     Loadable kernel modules allow the system administrator to dynamically add
     and remove functionality from a running system. This ability also helps
     software developers to develop new parts of the kernel without constantly
     rebooting to test their changes.

     Various types of modules can be loaded into the system. There are several
     defined module types, listed below, which can be added to the system in a
     predefined way. In addition, there is a generic type, for which the
     module itself handles loading and unloading.

     The LKM interface is used by performing ioctl(2) calls on the /dev/lkm
     device. Normally all operations involving Loadable Kernel Modules are
     handled by the modload(8), modunload(8), and modstat(8) programs. Users
     should never have to interact with /dev/lkm directly.

MODULE TYPES

     System Call modules
             System calls may be replaced by loading new ones via the LKM in-
             terface. All system calls may be replaced, but special care
             should be taken with the ioctl(2) system call, as it is used to
             load and unload modules.

             When a system call module is unloaded, the system call which was
             replaced by the loadable module is returned to its rightful place
             in the system call table.

     Virtual Filesystem modules
             Virtual filesystems may be added via the LKM interface.

     Device Driver modules
             New block and character device drivers may be loaded into the
             system with LKM. The major problem with loading a device driver
             is that the driver's device nodes must be exist for the devices
             to be accessed. They are usually created by instructing
             modload(8) to run an appropriate program when the driver has been
             successfully loaded.

     Execution Interpreters
             Execution interpreters allow the loading and execution of
             binaries which are normally not usable by the operating system.

     Miscellaneous modules
             Miscellaneous modules are modules for which there are not
             currently well-defined or well-used interfaces for extension. The
             user is expected to write their own loader to manipulate whatever
             kernel data structures necessary to enable and disable the new
             module when it is loaded and unloaded.

FILES

     /dev/lkm                LKM interface device
     /usr/include/sys/lkm.h  file containing definitions of module types
     /usr/share/lkm          example source code implementing several of the
                             modules types

SEE ALSO

     modload(8), modstat(8), modunload(8)

HISTORY

     The LKM facility was designed to be similar in functionality to the load-
     able kernel modules facility provided by SunOS 4.1.3.

AUTHORS

     Terrence R. Lambert <terry@cs.weber.edu>

BUGS

     Loading a bogus module is likely to kill your machine.

     Loadable streams modules should and will be implemented when a streams
     implementation is written.

MirBSD #10-current            September 4, 1993                              1

Generated on 2022-12-24 01:00:14 by $MirOS: src/scripts/roff2htm,v 1.113 2022/12/21 23:14:31 tg Exp $ — This product includes material provided by mirabilos.

These manual pages and other documentation are copyrighted by their respective writers; their sources are available at the project’s CVSweb, AnonCVS and other mirrors. The rest is Copyright © 2002–2022 MirBSD.

This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report — diffs preferred.

Kontakt / Impressum & Datenschutzerklärung