IT(4) BSD Programmer's Manual IT(4)
it - ITE IT8705F, IT8712F and SiS SiS950 hardware monitors
it0 at isa? port 0x290
The it driver provides support for the IT8705F, IT8712F and SiS950 hardware monitors to be used with the sysctl(8) interface. Most supported devices possess 15 sensors: Sensor Units Typical Use Fan0 RPM CPU Fan Fan1 RPM Fan Fan2 RPM Fan IN0 uV DC Core voltage IN1 uV DC Core voltage IN2 uV DC +3.3V IN3 uV DC +5V IN4 uV DC +12V IN5 uV DC Unknown IN6 uV DC -12V IN7 uV DC -5V IN8 uV DC VBAT Temp uK Motherboard Temperature Temp uK Motherboard Temperature Temp uK CPU Temperature For some devices, sensors' names and numbers will be different. Due to hardware limitations, fresh sensor data is only available every 1.5 seconds.
The it driver first appeared in OpenBSD 3.4.
The it driver was written by Julien Bordet <firstname.lastname@example.org>.
Interrupt support is unimplemented. MirOS BSD #10-current May 16, 2003 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.