ISDNTEL(4) BSD Programmer's Manual ISDNTEL(4)
isdntel - ISDN B-channel telephony interface driver
pseudo-device isdntel count
The isdntel driver provides an interface to the B-channel for telephony applications and is currently used by the isdnd(8) for answering machine support. The driver is part of the isdn4bsd package. The lower six bits of the driver's minor number are used to specify a unit number, whereas the upper two bits specify a functionality. Functionality zero is the usual telephony data stream i/o driver. Functionality one is used to enable commands to dial out and hang up and receive responses about the state of the dial out progress and status. This commands may change in the future, for details see the file /usr/include/netisdn/i4b_tel_ioctl.h and the isdntel(8) utility. The telephony data stream comes out of the line in a bit-reversed format, so the isdntel driver does the bit-reversion process in any case. Additionally, the user can specify to do A-law to mu-law, mu-law to A-law or no conversion at all in the isdntel driver by using the isdntelctl(8) utility. The driver is able to process several ioctl's: I4B_TEL_GETAUDIOFMT get currently used audio format conversion. I4B_TEL_SETAUDIOFMT set currently used audio format conversion. I4B_TEL_EMPTYINPUTQUEUE clear the input queue. For the I4B_TEL_GETAUDIOFMT and I4B_TEL_SETAUDIOFMT, the following param- eters are available: CVT_NONE do no A-law/mu-law audio format conversion. The conversion path looks like this: USER <--> bitreversing <--> ISDN-line CVT_ALAW2ULAW set set audio format conversion to do an audio conversion from A-law (on the ISDN line) to mu-law (in the userland). The read(2) conversion path looks like this: USER <-- mu-law/A-law <-- bitreversing <-- ISDN-line and the write(2) conversion path looks like this: USER --> mu-law/A-law --> bitreversing --> ISDN-line CVT_ULAW2ALAW set set audio format conversion to do an audio conversion from mu-law (on the ISDN line) to A-law (in the userland). The read(2) conversion path looks like this: USER <-- A-law/mu-law <-- bitreversing <-- ISDN-line and the write(2) conversion path looks like this: USER --> A-law/mu-law --> bitreversing --> ISDN-line
isdnd.rc(5), isdnd(8), isdntel(8), isdntelctl(8)
A-law and mu-law are specified in ITU Recommendation G.711.
The isdntel device driver and this man page were written by Hellmuth Michaelis <firstname.lastname@example.org>. MirOS BSD #10-current April 21, 1999 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.