MirBSD manpage: fd(4), stderr(4), stdin(4), stdout(4)

FD(4)                      BSD Programmer's Manual                       FD(4)

NAME

     fd, stdin, stdout, stderr - file descriptor files

DESCRIPTION

     The files /dev/fd/0 through /dev/fd/# refer to file descriptors which can
     be accessed through the filesystem. If the file descriptor is open and
     the mode the file is being opened with is a subset of the mode of the ex-
     isting descriptor, the call:

           fd = open("/dev/fd/0", mode);

     and the call:

           fd = fcntl(0, F_DUPFD, 0);

     are equivalent.

     Opening the files /dev/stdin, /dev/stdout, and /dev/stderr is equivalent
     to the following calls:

           fd = fcntl(STDIN_FILENO,  F_DUPFD, 0);
           fd = fcntl(STDOUT_FILENO, F_DUPFD, 0);
           fd = fcntl(STDERR_FILENO, F_DUPFD, 0);

     Flags to the open(2) call other than O_RDONLY, O_WRONLY, and O_RDWR are
     ignored.

FILES

     /dev/fd/#
     /dev/stdin
     /dev/stdout
     /dev/stderr

SEE ALSO

     tty(4)

MirBSD #10-current               June 9, 1993                                1

Generated on 2022-12-24 01:00:14 by $MirOS: src/scripts/roff2htm,v 1.113 2022/12/21 23:14:31 tg Exp $ — This product includes material provided by mirabilos.

These manual pages and other documentation are copyrighted by their respective writers; their sources are available at the project’s CVSweb, AnonCVS and other mirrors. The rest is Copyright © 2002–2022 MirBSD.

This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report — diffs preferred.

Kontakt / Impressum & Datenschutzerklärung