FAITH(4) BSD Programmer's Manual FAITH(4)
faith - IPv6-to-IPv4 TCP relay capturing interface
pseudo-device faith [count]
The faith interface captures IPv6 TCP traffic, for implementing userland IPv6-to-IPv4 TCP relay similar to faithd(8). A faith interface can be created at runtime using the ifconfig faithN create command or by setting up a hostname.if(5) configuration file for netstart(8). Special action will be taken when IPv6 TCP traffic is seen on a router, and the routing table suggests routing it to the faith interface. In this case, the packet will be accepted by the router, regardless of the list of IPv6 interface addresses assigned to the router. The packet is cap- tured by an IPv6 TCP socket, if it has the IN6P_FAITH flag turned on and it has matching address/port pairs. Thus, faith allows captured IPv6 TCP traffic to be relayed to some specific destination addresses. Userland programs, such as faithd(8) can use this behavior to relay IPv6 TCP traffic to IPv4 TCP traffic. The program can accept some specific IPv6 TCP traffic, perform getsockname(2) to get the IPv6 destination address specified by the client, and perform application-specific address mapping to relay IPv6 TCP to IPv4 TCP. The IN6P_FAITH flag on an IPv6 TCP socket can be set by using setsockopt(2), with level set to IPPROTO_IPV6 and optname set to IPv6_FAITH. To handle error reports by ICMPv6, some of the ICMPv6 packets routed to the faith interface will be delivered to IPv6 TCP, as well. To understand how faith can be used, take a look at the source code of faithd(8). As the faith interface implements a potentially dangerous operation, great care must be taken when configuring the faith interface. To avoid possible misuse, the sysctl(8) variable net.inet6.ip6.keepfaith must be set to 1 prior to use of the interface. When net.inet6.ip6.keepfaith is 0, no packet is captured by the faith interface. The faith interface is intended to be used on routers, not on hosts.
inet(4), inet6(4), faithd(8) Jun-ichiro itojun Hagino and Kazu Yamamoto, "An IPv6-to-IPv4 transport relay translator", RFC 3142, June 2001, ftp://ftp.isi.edu/in- notes/rfc3142.txt.
The FAITH IPv6-to-IPv4 TCP relay translator first appeared in WIDE hydrangea IPv6 stack. MirOS BSD #10-current April 10, 1999 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.