DPT(4) BSD Programmer's Manual DPT(4)
dpt - DPT EATA SCSI RAID adapter driver
dpt* at pci? dev ? function ? scsibus* at dpt?
The dpt driver provides support for the following SCSI adapters: DPT SmartCache III DPT SmartCache IV DPT SmartRAID III DPT SmartRAID IV
None of these messages should be encountered under normal circumstances. It should be noted that the list below is not complete. dpt0: readcfg failed - see dpt(4) The EATA configuration data did not appear upon request. This may be caused by older firmware. Generally the solution is to power-cycle the affected machine. dpt0: spurious intr A spurious interrupt was received from the HBA. dpt0: bogus status (returned CCB id NNNN) A corrupt or incomplete status packet was received from the HBA.
cd(4), ch(4), intro(4), pci(4), scsi(4), sd(4), st(4)
This manpage is inadequate. The dpt driver first appeared in OpenBSD 2.5.
The dpt driver was written by Andy Doran <firstname.lastname@example.org>, based upon the uha and bha drivers, which are the work of others.
The first (0th) and subsequent (for multi-channel cards) scsibus(4) should be attached at the dpt, because of the way the driver is written and OpenBSD scsi(4) layer design limitations. EATA adapters other than listed may function correctly with the dpt driver, however a definitive list is not available. Older firmware may prove problematic. It is recommended that the latest available firmware be used. Contact DPT for a firmware update. Older boards that do not support scatter-gather I/O or DMA are not sup- ported. An ISA front-end is needed. ECC formatted disk and arrays (i.e., with a sector size of 528 bytes) do not work correctly with the PM2041 and certain firmware revisions of the PM3334. MirOS BSD #10-current September 28, 1999 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.