MirBSD manpage: cy(4)
CY(4) BSD Programmer's Manual CY(4)
cy - Cyclades Cyclom-{4, 8, 16}Y asynchronous comms board device driver
cy0 at isa? iomem 0xd4000 irq 12
cy* at pci?
This driver provides an interface to Cyclades Cyclom-4Y, Cyclom-8Y and
Cyclom-16Y asynchronous multiport serial boards. These boards are based
around Cirrus Logic CD1400 communication controllers.
The device minor numbers for this driver are encoded as follows:
d c c u u u u u - bits in the minor device number
bits meaning
---- -------
uuuuu physical serial line (i.e., unit) to use
0-7 on a cyclom-8Y, 0-15 on a cyclom-16Y
cc card number
d dial-out flag
cy%d: tty input queue overflow Incoming characters have been discarded
due to a buffer overflow. This is caused by the process in control of the
device not read(2)'ing characters fast enough.
cy%d: receive fifo overrun Incoming characters have been discarded due
to a CD1400 channel overrun. This is caused by interrupts not being ser-
viced sufficiently quickly to prevent the 12 byte receive FIFO on a seri-
al channel from overflowing. Reducing the value of the RxFifoThreshold
#define from 8 to something smaller may help slow machines avoid this
problem. The driver must have been compiled with the LogOverruns option
defined (the default) in order for this condition to be logged.
com(4), intro(4), isa(4), pci(4), termios(4), tty(4)
Some ideas for the architecture of this driver's two-layer processing
model were derived from the fas 2.10 driver by
Uwe Doering <gemini@geminix.in-berlin.de> and the high-performance com
driver by
Bruce Evans <bde@kralizec.zeta.org.au>.
This work was made possible through the donation of a Cyclom-8Y board by
the manufacturer, Cyclades Corporation. However, neither Cyclades nor the
author make any warranties regarding this software, nor guarantees of
support.
The driver was written by Andrew Herbert <andrew@werple.apana.org.au>.
There is currently no BREAK handling - breaks are ignored. There is no
support for bad-character reporting, except via PARMRK. The Cyclom-[48]Y
boards do not listen to the RTS signal for receiver flow control. FIFO
overruns are only logged when the termios IGNPAR setting is enabled.
MirBSD #10-current October 5, 1993 1