CARDBUS(4) BSD Programmer's Manual CARDBUS(4)
cardbus, cbb - introduction to CardBus support
cbb* at pci? dev? function ? cardslot* at cbb? flags 0x0000 cardbus* at cardslot? pcmcia* at cardslot?
OpenBSD provides machine-independent bus support and drivers for CardBus devices. The flags are used with cardslot definition. The lowest order (rightmost) bit of flags defines the PC Card attach sequence at boot-time. When the bit is set, a PC Card in the slot is probed and attached immediately. However, the PC Card is probed after the kernel thread wakes up. If a PC Card is used as a boot device (e.g., CF card or network card), this bit should be set to 1.
OpenBSD includes the following machine-independent CardBus drivers, sort- ed by function and driver name:
dc(4) Intel 21143 and Xircom X3201-based Ethernet interfaces. fxp(4) Intel PRO/100 CardBus II Ethernet interfaces. rl(4) Realtek 8129/8139-based Ethernet interfaces. xl(4) 3Com 3c575 and 3c656-based Ethernet interfaces.
intro(4), pci(4), pcibios(4), pcmcia(4)
The cardbus driver first appeared in NetBSD 1.5. OpenBSD support was ad- ded in OpenBSD 2.7. MirOS BSD #10-current November 14, 1999 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.