BGE(4) BSD Programmer's Manual BGE(4)
bge - Broadcom BCM570x PCI gigabit ethernet adapter driver
bge* at pci? dev ? function ?
The bge driver provides support for various NICs based on the Broadcom BCM570x family of gigabit ethernet controller chips, including the fol- lowing: • 3Com 3c996-T • 3Com 3c996-SX • 3Com 3c996B-T • Dell PowerEdge 2550 integrated BCM5700 NIC • IBM xSeries 235 integrated BCM5703X NIC • IBM xSeries 305 integrated BCM5703X NIC • Netgear GA302T • SysKonnect SK-9D21 • SysKonnect SK-9D41 All of these NICs are capable of 10, 100 and 1000Mbps speeds over CAT5 copper cable, except for the SysKonnect SK-9D41 which supports only 1000Mbps over multimode fiber. It has two R4000 CPU cores and is PCI v2.2 and PCI-X v1.0 compliant. It supports multiple RX and TX DMA rings for QoS applications, rules-based receive filtering, and VLAN tag stripping/insertion as well as a 256-bit multicast hash filter. Addition- al features may be provided via value-add firmware updates. The BCM570x supports TBI (ten bit interface) and GMII transceivers, which means it can be used with either copper of 1000baseX fiber applications. Note how- ever the device only supports a single speed in TBI mode. Most cards also use the Broadcom BCM5401 or BCM5411 10/100/1000 copper gigabit transceivers, which support autonegotiation of 10, 100 and 1000Mbps modes in full or half duplex. The bge driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file. 10baseT Set 10Mbps operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (fast ethernet) operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes. 1000baseT Set 1000baseT operation over twisted pair. full-duplex and half-duplex modes are supported. 1000baseSX Set 1000Mbps (gigabit ethernet) operation. Both full-duplex and half-duplex modes are supported. The bge driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. The bge driver also supports one special link option for 1000baseT cards: link0 With 1000baseT cards, establishing a link between two ports re- quires that one port be configured as a master and the other a slave. With autonegotiation, the master/slave settings will be chosen automatically. However when manually selecting the link state, it is necessary to force one side of the link to be a mas- ter and the other a slave. The bge driver configures the ports as slaves by default. Setting the link0 flag with ifconfig(8) will set a port as a master instead. For more information on configuring this device, see ifconfig(8).
bge%d: couldn't map memory A fatal initialization error has occurred. bge%d: couldn't map ports A fatal initialization error has occurred. bge%d: couldn't map interrupt A fatal initialization error has occurred. bge%d: no memory for softc struct! The driver failed to allocate memory for per-device instance information during initialization. bge%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in a bus-master slot. bge%d: no memory for jumbo buffers! The driver failed to allocate memory for jumbo frames during initialization. bge%d: watchdog timeout The device has stopped responding to the net- work, or there is a problem with the network connection (cable).
arp(4), bce(4), brgphy(4), ifmedia(4), intro(4), netintro(4), pci(4), vlan(4), hostname.if(5), ifconfig(8)
The bge device driver first appeared in OpenBSD 3.0.
The bge driver was written by Bill Paul <firstname.lastname@example.org>. MirOS BSD #10-current September 27, 2001 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.