AMI(4) BSD Programmer's Manual AMI(4)
ami - American Megatrends Inc. MegaRAID Controllers
ami* at pci? dev ? function ? scsibus* at ami?
The ami driver provides support for the MegaRAID family of RAID controll- ers, including: Dell PERC2/DC, PERC3/DC, PERC3/DCL, PERC3/QC, PERC3/SC, Dell PERC4/DC, PERC4/SC, PERC4/Di, PERC4/Si, and CERC Hewlett-Packard 438, 466, and T LSI/AMI MegaRAID LSI/Symbios 523 SATA These controllers support RAID 0, RAID 1, RAID 5, JBOD, and superposi- tions of those configurations. Some cards support both I2O and a so-called `Mass Storage' mode of opera- tion. This driver only supports the `Mass Storage' mode; I2O mode is sup- ported by the iop(4) driver. Although the controllers are actual RAID controllers, the driver makes them look just like SCSI controllers. All RAID configuration is done through the controllers' BIOSes.
intro(4), iop(4), pci(4), scsi(4), sd(4)
The ami driver first appeared in OpenBSD 2.9.
The ami driver was written by Michael Shalayeff <firstname.lastname@example.org>. MirOS BSD #10-current February 27, 2004 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.